It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I've got myself into a bit of a pickle trying to mod Baldur's Gate (I'm using the GOG versions of BG1 &2). I successfully installed EasyTutu to the following directory : C\Games\BGTutu, and after a bit of tweaking via bgconfig it worked like a charm. Then I managed to work out how to install Unfinished Business and I'm assuming it worked (I selected the components I wanted to install and launched the game again successfully), though I haven't played the game yet to test it. Then I tried to install the widescreen mod and everything went pear-shaped.

I double-clicked on the widescreen application and pointed it towards C:\Games\BGTutu and a box came up asking me what resolution I wanted. I have a 16:9 monitor and chose 960*540 because I want to lose the black borders but I still want to see detail on armour and weapons etc. and don't want to be zoomed too far out. I assumed it would have installed correctly but when I double-click on my desktop icon I get an instant CTD. So I decided to uninstall BGTutu and start again, but to my horror it does not appear in the Programs list (Control Panel > Programs), so I don't know where it is ! I'm assuming that simply deleting my BGTutu folder will not uninstall the game ?

The IE games are my favourite games of all time so help would be much appreciated.
I should posted this as a question / problem, sorry.
avatar
Theoclymenus: after a bit of tweaking via bgconfig it worked like a charm.
Did the vanilla installs work with all defaults in bgconfig, with just putting the hardware sliders on full?
What did you change in bgconfig?
avatar
Theoclymenus: Then I managed to work out how to install Unfinished Business and I'm assuming it worked (I selected the components I wanted to install and launched the game again successfully), though I haven't played the game yet to test it.
If it installed correctly you will see it listed in the WeiDU.log
avatar
Theoclymenus: Then I tried to install the widescreen mod and everything went pear-shaped.

I double-clicked on the widescreen application and pointed it towards C:\Games\BGTutu and a box came up asking me what resolution I wanted. I have a 16:9 monitor and chose 960*540 because I want to lose the black borders but I still want to see detail on armour and weapons etc. and don't want to be zoomed too far out. I assumed it would have installed correctly but when I double-click on my desktop icon I get an instant CTD.
Your problem is you chose a resolution your monitor can't display.
The lowest 16:9 will be 1280x720.

Right click on your desktop/ screen resolution/ advanced settings/ list all modes. (thats what you get to chose from)
You could play 800x600 & lose the black bars by adjusting the scaling to full screen in the Nvidia Control Panel.
But it will pull it out of shape a bit.
avatar
Theoclymenus: So I decided to uninstall BGTutu and start again, but to my horror it does not appear in the Programs list (Control Panel > Programs), so I don't know where it is ! I'm assuming that simply deleting my BGTutu folder will not uninstall the game ?
That is because TuTu is basically just a BG2 Mod.
Yes you could just delete the TuTu directory.
But you probably need to just go into your TuTu root directory & run setup-widescreen.exe & uninstall it.
Then run it again an chose a resolution supported by your monitor/displaycard.
Thanks very much for the reply, olnorton. I think I'll just try to uninstall and reinstall by deleting the Tutu directory. I did try to run the setup-widescreen.exe again and I chose uninstall (U) but it wouldn't let me uninstall for some reason. I didn't make a note of exactly what it said. Hopefully I can just start from scratch again. I chose 960*540 because it is supposed to be a 16:9 aspect ratio resolution and I didn't want the resolution too high because I wanted to still be able to see details. I didn't know that 1280*720 was the lowest resolution available. I'll try again in the morning, thanks a lot for your help.
avatar
Theoclymenus: I didn't know that 1280*720 was the lowest resolution available.
The widescreen mod will support 960x540 if your monitor will.
Depending on your monitor & display card & drivers. you may be able to set it up as a custom resolution.
If you can display your desktop at that, the widescreen mod can use it.
Yes, the vanilla installs work perfectly, especially after I have increased the framerate in the bgconfig (this also works perfectly for me with BG2 and both IWDs). The only problem I have with the vanilla versions is a slightly flickering cursor. I read that this can be rectified by turning Hardware Acceleration on in the config and I tried it and it does work but gives me green water. I know that there is a patch for this - the "degreenifier" - but I had already installed Unfinished Business by this point so I was going to start again anyway. I just thought I would try to get the widescreen mod working first. It was a trial run really and I haven't started the game yet , so as long as I can uninstall Tutu there's no harm done.
What I want, ideally, is get all the IE games to fit my screen (i.e. to get rid of the black borders), though I'm not keen on the idea of too high a resolution, which is why I tried for 960*540. I'd like to play BG using the BG2 engine, in a slightly higher resolution, though I would have preferred to keep the old "stone" UI. Apart from all I'm interested in at the moment is Unfinished Business. If I can't get the widescreen mod working I'm quite happy to play the game with the black borders.
avatar
Theoclymenus: What I want, ideally, is get all the IE games to fit my screen (i.e. to get rid of the black borders), though I'm not keen on the idea of too high a resolution, which is why I tried for 960*540. I'd like to play BG using the BG2 engine, in a slightly higher resolution, though I would have preferred to keep the old "stone" UI. Apart from all I'm interested in at the moment is Unfinished Business. If I can't get the widescreen mod working I'm quite happy to play the game with the black borders.
Ok I just run it on 960x540.
If you have a Nvidia Card, here is what I did.
In the Nvidia Control Panel /Change Resolution /Customize /Create Custom Resolution
Put in 960X540 & test it. Then except it.
Then change your resolution back to default.
The custom resolution will stay stored & you will be able to use it with the widescreen mod.
This is 960x540

This will work for all IE games.
If you choose a 16:9 & still get black bars, set desktop scaling to fullscreen.
Attachments:
960x540.jpg (292 Kb)
Post edited January 15, 2013 by olnorton
Thank you very much, olnorton, I've just got the whole thing working again, albeit at 1280*720, as you suggested. I deleted the BGTutu directory, reinstalled it, installed the degreenifier, turned Hardware Acceleration on, so no flickering cursor and BLUE water (though I kind of liked the green water tbh !) Then I installed Unfinished Business mod and had a look at the WeiDu log (double-clicked on the WeiDU Text Document in my C:\Games\BGTutu directory) and everything was there. Then I installed the widescreen mod and set the resolution to 1280*720 and I must say it looks beautiful so perhaps I won't change it from this. I'll try what you said re the 960*540 resolution and (if it works) see which I prefer. Thanks very much for your help, and I would also like to thank the writer of EasyTutu (Macready ?) for making such a great and user-friendly mod. This game, and all the IE games for that matter, has such an amazing atmosphere :)
avatar
Theoclymenus: Thank you very much, olnorton, I've just got the whole thing working again, albeit at 1280*720, as you suggested. I deleted the BGTutu directory, reinstalled it, installed the degreenifier, turned Hardware Acceleration on, so no flickering cursor and BLUE water (though I kind of liked the green water tbh !) Then I installed Unfinished Business mod and had a look at the WeiDu log (double-clicked on the WeiDU Text Document in my C:\Games\BGTutu directory) and everything was there. Then I installed the widescreen mod and set the resolution to 1280*720 and I must say it looks beautiful so perhaps I won't change it from this. I'll try what you said re the 960*540 resolution and (if it works) see which I prefer. Thanks very much for your help, and I would also like to thank the writer of EasyTutu (Macready ?) for making such a great and user-friendly mod. This game, and all the IE games for that matter, has such an amazing atmosphere :)
I play them all @ 1280X720 myself, but I must say I don't mind the bigger avatars @ 960X540 (all be it slightly blocky)
avatar
Theoclymenus: Then I installed the widescreen mod and set the resolution to 1280*720 and I must say it looks beautiful so perhaps I won't change it from this. I'll try what you said re the 960*540 resolution and (if it works) see which I prefer.
I play at a custom resolution of 1066x600 - it makes the game use the 800x600 GUI set (only wider) without any black borders. Just another option to think about. (You can change the res anytime by running widescreen setup again)

EDIT: By the way, there is a Tutu GUI mod (download links on the right) to restore the stone look of BG1. Have not tried it myself. I think it should work with widescreen mod so long as widescreen is installed last.
Post edited January 15, 2013 by anamorphic
avatar
anamorphic: I play at a custom resolution of 1066x600 - it makes the game use the 800x600 GUI set (only wider) without any black borders. Just another option to think about. (You can change the res anytime by running widescreen setup again)
Does any resolution with a y axis over 600 get the 800x600 GUI set?
1072x603 being the next true 16:9.
avatar
olnorton: Does any resolution with a y axis over 600 get the 800x600 GUI set?
I believe so, up until 1024x768 which uses the next one. If I use 1280x720 for example I get black borders on the top/bottom of the 4:3 screens (inventory, etc), because the GUI set is fixed at 600 vertical. I'm not a fan of that shift because it takes me out of the game a bit.
avatar
olnorton: Does any resolution with a y axis over 600 get the 800x600 GUI set?
avatar
anamorphic: I believe so, up until 1024x768 which uses the next one. If I use 1280x720 for example I get black borders on the top/bottom of the 4:3 screens (inventory, etc), because the GUI set is fixed at 600 vertical. I'm not a fan of that shift because it takes me out of the game a bit.
Well I tried the 1072x603 for an hour or so, but I think I prefer 1280x720, probably just because I'm used to it.
Unfortunately the Customize option in my Nvidia control panel is greyed out - it's an Alienware laptop and they tend to do this kind of thing for some reason known only to themselves.It's a shame because I would have liked to try the 1066*600 resolution but I'm happy enough with 1280*720. Thanks for your help, much appreciated.