It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hi. While I don't have Baldur's Gate or any IE games from GOG as yet (waiting for a good sale), I have a boxed copy of both games and with a few mods, they run flawlessly. No flickering, widescreen works like a charm etc... It was only today that I checked out the config and saw that I hadn't checked 3D Accelerations. Curious, I checked it along with 32bit textures and when I played the game I noticed some lag... Not much at first, but it got worse with many characters on the screen. The only graphical difference I saw was that the fog of war had smoother edges. When I disabled 32bit textures alone, leaving the acceleration still checked, I got a huge improvement in performance. Also since I use TUTU, when I installed the degreenifier to BG1, I noticed that I got horrible lag when near water (like in Naskel).

So, my question(s) (after all that text) is this: why is the 3D acceleration and 32bit textures causing so much lag and is there any major graphical benefit to using it? Why does the TUTU degreenifier cause BG1 to lag majorly?

My specs btw are:
Windows 7 64bit
Intel Pentium CPU 2.20GHz
4Gb RAM

Mods I use are: widescreen mod, fixpack and TUTU
No posts in this topic were marked as the solution yet. If you can help, add your reply
You neglected to mention the most important spec: graphics card. There is zero lag on mine with a budget GTX550 and every option you said enabled. Having 3D uses the graphics card (OpenGL) rather than CPU, so you get smoother looking fog and spell effects, etc.
I guess I forgot to mention that... Yeah it's an Intel Integrated Graphics.... Do you think that's why it lags? Anyway, is the difference between having 3D Acceleration on or off that noticeable?
Don't know about the degreenifier, buy my amd C50 1ghz (HD6250, granted not the fastest) lags as well in openGL, while running perfectly in software mode.
This is with Baldur's Gate Trilogy.
Post edited December 18, 2012 by Gromuhl
I think it's probably my graphics card since I have *shudders* integrated graphics. It runs fine in software mode
Just thought I'd throw this out there incase.

If you have a bottomless bag of holding and have to much in it the game will lag like crazy, or more specifically it will freeze for a moment every few seconds.

Edit, missed your last post. In that case I'd say there's a good chance your integrated graphics isn't up to running it in hardware.
Post edited December 19, 2012 by Grogger
I actually prefer to play with 3D Acceleration off. I think the game looks better that way, honestly. However, you WILL need to have "3D Animations" checked in the config program.

This avoids the issues with integrated cards as well, since it uses only your CPU, and even on a netbook you're almost guaranteed to have more than enough processor for BG2.
Yeah I have 3D Animations turned on with no problem. I've been playing BG1 and 2 for years without 3D Acceleration. I just thought I'd turn it on to see if there was a difference. The only thing I noticed was that the fog of war had less rough edges... But yeah, I don't mind playing with it off.