It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Like the topic title says, every time I run baldur.exe for BG2 and hit "play" the game asks me to run config since it's my first time playing the game, even though it's obviously not because I saved config settings like 3 times already.

Also, I'd run bgmain.exe directly but it asks for admin privileges each time which is annoying.

I have the game installed to "D:/programs/Baldur's Gate 2/", so it shouldn't be the common problem with the Program Files directory, what gives?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Oh, apparently you have to edit your registry to change the accessibility data on bgmain.exe so that it'll run without admin.

Well that was stupid.

Sorry about the useless topic now guys, mods delete this I guess.
avatar
Lokathor: Oh, apparently you have to edit your registry to change the accessibility data on bgmain.exe so that it'll run without admin.
You never need to edit the registry to run a program with admin rights, provided you have admin privileges. Just right click on bgmain.exe and select 'Properties', then choose the 'Compatibility' tab. Check off the 'Run this as administrator' checkbox, apply, ok.
Yeah, I did that, it didn't work out. Until I did the weird reg-edit thing.

I do not know why, but since I know enough to tamper with reg-edit I probably should learn why because reg-edit is not a toy.

Don't tamper with reg-edit, folks at home.
avatar
Lokathor: Like the topic title says, every time I run baldur.exe for BG2 and hit "play" the game asks me to run config since it's my first time playing the game, even though it's obviously not because I saved config settings like 3 times already.

Also, I'd run bgmain.exe directly but it asks for admin privileges each time which is annoying.

I have the game installed to "D:/programs/Baldur's Gate 2/", so it shouldn't be the common problem with the Program Files directory, what gives?
im having the exact same problem, how exactly did you solve it? How exactly do I modify the registry?
avatar
Aran_Linvail: im having the exact same problem, how exactly did you solve it? How exactly do I modify the registry?
Don't. You do NOT need to alter the registry. Simply uninstall the game and then reinstall OUTSIDE of Program Files.
avatar
Aran_Linvail: im having the exact same problem, how exactly did you solve it? How exactly do I modify the registry?
avatar
Hickory: Don't. You do NOT need to alter the registry. Simply uninstall the game and then reinstall OUTSIDE of Program Files.
The game is installed outside Program Files, its on C/GOG Games/Baldurs Gate 2
avatar
Hickory: Don't. You do NOT need to alter the registry. Simply uninstall the game and then reinstall OUTSIDE of Program Files.
avatar
Aran_Linvail: The game is installed outside Program Files, its on C/GOG Games/Baldurs Gate 2
Fair enough, but you said: "im having the exact same problem".

Go into the game's installation folder and run BGConfig.exe. Set up your options in there. Once you have done that, open your baldur.ini file and check under [Program Options] that the following are true:

Installing=0
Install Type=3
First Run=0

Also, make sure your shortcut is not running Baldur.exe. The shortcut should point to BGMain.exe .
Post edited June 14, 2014 by Hickory
Crazy thing, I just tried it before doing any of the changes you ust told me and it worked like magic. It's madness, yesterday after 1231239913 tries it kept bothering me. Oh well, thanks for the tips anyway :)