It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Right so I launch the game either with or without GOG Galaxy. Loading logo appears on the bottom right, It tells me it is reading Downloadable content, and then the screen remains black and nothing happens. What's causing this?
I have a GTX 970M which I am certain the game can run on and I have Windows 10. I can run any other game I have just fine. Maybe it's a video codec issue because the game needs to load the cutscenes but doesn't load the proper codec or something?
Try uninstalling codecs in your system.
I was going to make another thread but I apparently can't at the moment, so I'll just stick my thread here as it's for the same reason just a different cause:

Ys VII Crashing and Windows 10 V2004:

I had updated to Windows 10 v2004 not too long ago, and I was trying to run Ys VIII (I was playing other games, so I hadn't touched it in a while) when I realized that the game was constantly crashing (immediate black screen freezing). I thought maybe my files weren't up to date, but they were (both for the game [latest offline installers] and my GPU drivers, although when I checked in Galaxy it installed a 14MB update). I had heard about a bug linked to drive letters, and tried to fix it to no avail. I was about to start a thread about Ys VIII's inexplicable crashing, when I realized that not only did Ys VIII not work but also Ys VII and Celceta (they didn't even show a crash screen, they just didn't run). Running as an administrator, disabling full screen optimizations, and changing the compatibility settings all did nothing. Neither did playing with the .ini settings.

Now when the new version of Windows 10 came out, I had heard about a new graphical settings feature "Hardware-accelerated GPU scheduling", and that it provided a performance boost. I had tried some of my other games like Death Stranding, RE3 Remake, and for the three weeks that it was turned on there were no problems, but for some reason the Ys games stopped working. I turned Hardware-accelerated GPU scheduling off, restarted my PC, and poof, everything works again.

I've never heard of this happening to anyone else (so I guess it was just my particular hardware/software setup), but if it did, here's a possible fix.

These are my PC Specs:

CPU: Ryzen 5 2600X @ 4.05GHz
GPU: EVGA SC Ultra GeForce RTX 2060 Super
MOBO: B450 Gaming Pro Carbon AC
RAM: 32GB (16x2 DDR4 2666)
OS: Windows 10 v2004
HDD(s): WD 2TB Blue (for OS), WD 1TB Black, WD 2TB Gold, WD 6TB Gold