It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Step 1. Start the game

Step 2. Open task manager

Step 3. Right click the XIII.exe PROCESS (not task, PROCESS)

Step 4. Select ''set affinity'' and unclick all CPUs except for one.

TADA!!!!! You have to do this each time you start it, but if anyone knows how make it do it automatically using a .bat, I would appreciate it a lot. I don't know a single thing about shell scripting.
Attachments:
Post edited August 21, 2012 by ggf162
Good idea, but it doesn't work (Win7-64 here). The problem is sound-related. Whether it's an issue with the Unreal engine, or DX9, I can't say, but the only sure fix is to turn off sound once it starts occurring. You do this by editing the xiii.ini file, and change UseSound=False The game ran fine for me till after blowing up the SPAD ammo depot, just before battling McCall. Framerate goes to zero and the cpu is pegged. You can effect how soon this occurs by playing with SoundPCBufSize, try 128 and notice it's effect on voice speed; restore it when finished playing with it though. I haven't played far enough to know if the problem goes away once a new chapter is reached or not, but if this is happening to you disable sound as above, and keep saving as you reach checkpoints, and try reenabling sound periodically. BTW, the command to set cpu affinity is C:\Windows\System32\cmd.exe /C start /affinity 1 C:\Games\XIII\system\XIII.exe

UPDATE: Upon finishing the level where the bug occurred, I reset UseSound=True and had no further issues for the remainder of the game, yay!
Post edited October 10, 2012 by rsquires