It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I was getting this error on the Steam version of this game, couldn't figure out how to fix it, so I bought the GOG version...and it still freaking happens!

Typically it happens during UFO interception. The UFOs spawn, I send my vehicles to attack. Once combat starts, a whole bunch of red text and numbers appear on screen and the game locks up. I've spent hours and hours trying to figure out how to fix this but to no avail. I've tried all sorts of config file configurations, nothing seems to work. I've tried the (extremely generic bullshit) troubleshooting steps listed here under Support. I'm just running the straight, clean installed version, on Windows 10.

From what I've been able to glean it's from the Core setting using the Dynamic option (either set to Dynamic or set to Auto). I've tried setting it to Normal, which doesn't use the Dynamic Core setting, but I still get the same crash.

I have a screenshot of it but the forum won't let me link it.
Post edited March 06, 2018 by endersblade
No posts in this topic were marked as the solution yet. If you can help, add your reply
So you're running which one?
I read this as being that he has tried running both Steam and GOG versions, and neither work for him.
endersblade: I bought the GOG version...and it still freaking happens!
I suggest you contact GOG support. I fully expect that they will be as unhelpful as the generic troubleshooting steps that already failed you, but contacting them will make them aware that the game does not necessarily work out-of-the-box on a supposedly supported platform. Additionally, should you decide to seek a refund on the GOG version due to inability to use it, they will insist that you first humor their useless attempts at troubleshooting.
endersblade: I have a screenshot of it but the forum won't let me link it.
Attach it instead. The forum permits common image types. They will not appear inline, but will be archived with the post, which is better long term anyway.

If you are not specifically attached to the DOSBox experience, I suggest you try OpenXCom. It is a modern reimplementation of XCom, has numerous quality of life improvements, and runs natively on modern platforms. It will require original XCom data (so your purchase is not a waste), but will not reuse any of the original code.
I know what Open XCOM is. I've played it for years. I'm trying to play Apocalypse, not X-COM. OpenApoc isn't quite to the state of retail. I don't want to play an unfinished game, I want to play the real thing. I've played the DOSBox version from Steam before, many times actually, through to the end and never experienced this issue. It's just NOW that I'm having it, and it's happening to both the Steam and GOG versions. I don't have any idea what in the world is causing it.

I'm going to wipe and reinstall my OS this weekend (it's been a long time coming) and I'll give it a shot after that. If it's still borked, I'll switch to OpenApoc.

Ok there, looks like I got them posted. One shows the DYNX86 spam error, the other shows what pops up when the game crashes.

For the record I have tried DOSBox .72, .73, .74, and the x64 SVN version. I get the same exact error in every one of them.
Post edited March 07, 2018 by endersblade
I THINK I figured it out. I'm not several hours into a game and haven't crashed once.

First, I set the core to simple.

At the bottom of the config file you'll see settings for XMS, EMS and UMB. I just set all of them to False. I don't know if it was just one or two of these three settings, but turning them all off made the error and crash go away!

Hopefully this will help anyone else out who runs into this issue. It worked for both the GOG version as well as the Steam verison.
Post edited March 09, 2018 by endersblade