It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
high rated
Hello,
I noticed that various people in here were asking for this, so I present you a plugin to enable windowed mode during the gameplay process in Worms 2, as well as a variety of other features:
Fix bad colors on Vista and 7 for good: this wrapper converts the graphics to render in 32-bit on the outside. This finally eliminates any need for the old color fixes.
Minimize the game using the Shift+Esc key combination (like in Worms Armageddon), or by switching out with Alt+Tab
● Enable or disable the window border ("Border" in the ini file) and move the window around (you'll need to perform Alt+Tab, then drag the window caption to move it). If the size of the window matches either height and/or width of your desktop resolution, the border will be automatically disabled, imitating fullscreen.
● Improve game performance on Windows 8, 10 and newer (since Windows 8, the old DirectDraw has lost performance in various games due to the new emulation)
● Make the game DPI-aware: this is useful if your system DPI is set to a value other than 100% and 125%. Extremely useful on Windows 8.1+ due to the abolition of the old, Windows XP-styled scaling, and the DPI virtualization enforcement (blurry mess instead of a window).

The core of this is wndmode.dll: a component of the D3Dhook library (from D3Dwindower by menopem), edited by VEG to be usable as an independent DLL. I have then written a companion to load it and solve the issue with bad cursor position (which was leading to freezes) in windowed mode. This was a lot easier here than a similar companion for W:A and WWP, because after Worms 2 they started using a bad menu system that caused a lot of problems. Worms 2 was still fully PC-oriented and thus its menus are windowed and using the proper technology.

You can download the archive here.

The installation is simple: all you need to do is to unpack the archive's contents into the directory where Worms 2 is installed.
Better don't touch any settings except the "Border" and "SizingBorder" in the ini file. Always make sure that you have a backup before experimenting, and that you know what you're doing.

Note: if you applied any "Compatibility options" or fixes before installing windowed mode, please disable them now. The game will not run if some of those are enabled (such as "limited colour mode").

Also it's extremely useful to run this module in combination with another plugin I made: </span>, to change the window size (resolution) to any value. It's described [url=https://www.gog.com/forum/worms_series/worms_2_resolution_change_hackpatch/post3]here.
Basically, change the ScreenWidth and ScreenHeight values in the ReSolution.ini file to whichever ones you need. Some of the files in there may coincide with the ones in this archive: this is normal, it doesn't matter if you choose to replace or skip them.
The more recent versions of ReSolution also allow you to resize and zoom the game window directly during the game! Should be enabled by default. Use the mouse wheel for zooming.
Post edited January 07, 2017 by StepS_
avatar
StepS_: Hello,
I noticed that various people in here were asking for this, so I present you a plugin to enable windowed mode during the gameplay process in Worms 2, as well as a variety of other features:
Fix bad colors on Vista and 7 for good: this wrapper converts the graphics to show up in 32-bit color externally. This finally eliminates any need for the old color fixes.
Minimize the game using the Shift+Esc key combination (like in Worms Armageddon), or by switching out with Alt+Tab
● Enable or disable the window border ("Border" in the ini file) and move the window around (you'll need to perform Alt+Tab, then drag the window caption to move it). If the size of the window matches either height and/or width of your desktop resolution, the border will be automatically disabled, imitating fullscreen.
● Improve game performance on Windows 8 and newer (since Windows 8, the old DirectDraw has lost performance in various games due to the new emulation)
● Make the game DPI-aware: this is useful if your system DPI is set to a value other than 100% and 125%. Extremely useful on Windows 8.1 due to the abolition of the old, Windows XP-styled scaling, and the DPI virtualization enforcement (blurry mess instead of a window).

The core of this is wndmode.dll: a component of the D3Dhook library (from D3Dwindower by menopem), edited by VEG to be usable as an independent DLL. I have then written a companion to load it and solve the issue with bad cursor position (which was leading to freezes) in windowed mode. This was a lot easier here than a similar companion for W:A and WWP, because after Worms 2 they started using a bad menu system that caused a lot of problems. Worms 2 was still fully PC-oriented and thus its menus are windowed and using the proper technology.

You can download the archive here.

The installation is simple: all you need to do is to unpack the archive's contents into the directory where Worms 2 is installed.
Better don't touch any settings except the "Border" in the ini file. Always make sure that you have a backup before experimenting, and that you know what you're doing.

Note: if you applied any "Compatibility options" or fixes before installing windowed mode, please disable them now. Else they would only make bad, not good.

Also you can use this windowed mode in combination with another plugin I made: </span>, to change the window size (resolution) to any value. It's described [url=http://www.gog.com/forum/worms_series/worms_2_resolution_change_hackpatch/post3]here. Some of the files in there may coincide with the ones in this archive: this is normal, it doesn't matter if you choose to replace or skip them.
That's the only way of resizing the window. Once the game has started, you can't extend or shrink the window: the workspace is constant (and changing its size would just either compress or stretch the graphics).
Wow, this patch works great! Worms 2 can now run on Windows 7 without any messed up colors! But I can't figure out how to adjust the "window" since it takes up the full screen. I still have to Alt+Tab to see anything else. Is there a way to adjust the window?
avatar
IronArcturus: Wow, this patch works great! Worms 2 can now run on Windows 7 without any messed up colors! But I can't figure out how to adjust the "window" since it takes up the full screen. I still have to Alt+Tab to see anything else. Is there a way to adjust the window?
To change this, open the W2.ini file (used by the ReSolution module) and reduce the ScreenWidth and ScreenHeight to whatever one you want. Then the game will appear as a window. If the width/height of the window match the width/height of your desktop resolution, then the border will be hidden and you'd see it in an imitated fullscreen mode that you have just described. :)

Edit: added a note about this into the top post. Also I think it's best to shrink huge quotes while replying. so that new readers could easily navigate the page. Just a note ;)
Post edited March 23, 2014 by StepS_
Thanks for the reply! Sorry about the large block of text. When a user clicks the reply button on here, the forum auto-includes all of the previous text for some reason.

I made that W2.ini change you suggested and it worked! I also found out that in Windows 7, both patches seem to work best if the user launches "frontend.exe" instead of the usual GOGLauncher.exe file. The GOG Launcher tends to crash the game for some reason.

Also, I was wondering, do you know if there is a way to get rid of those black brackets that show on the edges when the game goes into Replay Mode? If a user has the resolution set too high, the replay mode brackets appear in the middle of the screen and it's a bit distracting.

Thanks for all of your hard work! :) It's great to be able to play Worms 2 on a modern system again!
avatar
IronArcturus: I made that W2.ini change you suggested and it worked! I also found out that in Windows 7, both patches seem to work best if the user launches "frontend.exe" instead of the usual GOGLauncher.exe file. The GOG Launcher tends to crash the game for some reason.

Also, I was wondering, do you know if there is a way to get rid of those black brackets that show on the edges when the game goes into Replay Mode? If a user has the resolution set too high, the replay mode brackets appear in the middle of the screen and it's a bit distracting.
Hmm that's interesting, I haven't yet installed the gog launcher here on this computer, but I'll do it soon and tell you what might be the cause.
About the black brackets: yeah, I was thinking about it as well. What would be best to do: removing them at all or attempting to fit the arbitrary resolution?
avatar
IronArcturus: I made that W2.ini change you suggested and it worked! I also found out that in Windows 7, both patches seem to work best if the user launches "frontend.exe" instead of the usual GOGLauncher.exe file. The GOG Launcher tends to crash the game for some reason.

Also, I was wondering, do you know if there is a way to get rid of those black brackets that show on the edges when the game goes into Replay Mode? If a user has the resolution set too high, the replay mode brackets appear in the middle of the screen and it's a bit distracting.
avatar
StepS_: Hmm that's interesting, I haven't yet installed the gog launcher here on this computer, but I'll do it soon and tell you what might be the cause.
About the black brackets: yeah, I was thinking about it as well. What would be best to do: removing them at all or attempting to fit the arbitrary resolution?
I think an option to just remove the Replay Brackets might be for the best since they really don't do much for the game.
avatar
IronArcturus: Sorry about the large block of text. When a user clicks the reply button on here, the forum auto-includes all of the previous text for some reason.
If only there was some way to manually edit it before posting. ;)
Your plugin did wonders on Windows 7 32-bit here, thank you!
This works in w8.1 also.

Thank you very much dude.
Thanks to this patch I was finally able to run the game under Ubuntu in my windows 8.1 virtual machine. I am still having problems though. In particular with the mouse integration. The position of the mouse pointer in the game does not coincide with the position of my pointer. Also, when I try to move the mouse, the pointer moves at warp speed, making almost impossible to use those weapons that require a mouse click like missiles or air strikes. Is there any way to slow the mouse while in the game?
avatar
fancazzopoli: Thanks to this patch I was finally able to run the game under Ubuntu in my windows 8.1 virtual machine. I am still having problems though. In particular with the mouse integration. The position of the mouse pointer in the game does not coincide with the position of my pointer. Also, when I try to move the mouse, the pointer moves at warp speed, making almost impossible to use those weapons that require a mouse click like missiles or air strikes. Is there any way to slow the mouse while in the game?
This is an issue with running all 2nd-gen Worms games (W2, WA, WWP) in a Virtual Machine such as VMware, but doesn't happen on all VMware installations. The mouse cursor might be ultra-fast and I'm not sure about the way to resolve this issue (you could try changing some properties of your VM e.g. where it enables mouse cursor acceleration).
Post edited July 23, 2015 by StepS_
First of all thank you very much for your help and share.
I love Worms2, unfortunatelly I can't play ti since I don't use Windows XP. Never I could run it at W7, W8, W8.1 or now W10.
With "frontend.exe" I get the error "No Audio CD".
With "worms2.exe" I get a "Visual C++ Runtime" error.
No matter which patch or setting I try, it doesn't work.

Please help!!!
Is there any way to get the ReSolution module to work with Worms Armageddon?
avatar
IronArcturus: Is there any way to get the ReSolution module to work with Worms Armageddon?
No. The module was made specifically for W2 and WWP, because ReSolution's main purpose is to enable the use of high resolutions in-game, which is already present in WA. If you're talking about the extra features such as zoom and window resizing, then that's not possible in WA currently (mainly because there are many different renderers), but should be in the future. The way it's done for W2 and WWP involves a very specific DDraw surface hack I made, which can't just be used in WA (and can't be used with D3D9, of course)
Post edited January 07, 2017 by StepS_
avatar
StepS_: No. The module was made specifically for W2 and WWP, because ReSolution's main purpose is to enable the use of high resolutions in-game, which is already present in WA. If you're talking about the extra features such as zoom and window resizing, then that's not possible in WA currently (mainly because there are many different renderers), but should be in the future. The way it's done for W2 and WWP involves a very specific DDraw surface hack I made, which can't just be used in WA (and can't be used with D3D9, of course)
Thanks for replying back! But are you sure there is no way to enable windowed-mode with ReSolution and WA? I tried running it myself and the game almost worked. But it was the Level Selection window that kept blocking the game window with no way to move it. Is there a way to fix that?