It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just purchased New Order and I am experiencing "game not responding" at almost every other loading screen. I have a 2080ti, i9, and 32GB of ram so I don't believe the problem is my PC.

pcgamingwiki says the fix is updating my drivers, but they are up to date.
(Google translate) Look at my post, I had the same problem as you. Maybe this is the solution for you too.
Post edited February 20, 2020 by FlaW313
Thank you! The loading times still seem kinda weird but I think it did fix the crashing.
(Google Translate) You're welcome !

Yes, I also find that the loading times are still a bit long for this game, while I launch "The Witcher 3" in 30 seconds maximum (ultra quality / 2K resolution) ...
However, I have a largely sufficient PC (i7-4790K + 1080GamingX 8GB Vram + 32GB RAM) for "Wolfenstein New Order".

Anyway, the most important thing is to be able to play without crashing.
Post edited February 22, 2020 by FlaW313
Well I thought it worked but it now it's happening again. Cut scenes and deaths seem to be a major problem.
Vonyor: Well I thought it worked but it now it's happening again. Cut scenes and deaths seem to be a major problem.
Have you see ? :

Post edited February 23, 2020 by FlaW313
I tried submitting an support request here at gog and it crashed too...

Well I've seen with the Rivatuner that the RAM usage is going up steadily EVERY SECOND until the game becomes unresponsive.
It starts at about 4GB and goes up to 12GB when it crashes for me.

Very important note is that the console spews error messages regarding STEAM STATS, also every second or so.
Those two things seem very inter-related.

The game in its current state is playable only in 20-minute intervals, at best.
The long cutscenes and/or dying often crash the game even if the memory leak doesn't.
Post edited February 23, 2020 by Kugelstoesser
i have the same. the game is borderline unplayable for me.

fullscreen, windowed full screen, no difference.
I had the same problems of crashing after completing a level or from cut scenes. I verified the integrity of the game files in GoG Galaxy, and it downloaded 128mb. Something didn't run right during the initial installation. Load times have been much better since and I haven't crashed as much. Hope this helps and hopefully GoG fixes the install process. I still get crashes but it isn't as bad as before.
Post edited February 27, 2020 by Monkey-Tamer
- Another possible solution to these problems.
The game does not seem to support a higher speed of 60 FPS (on my 3 PCs).
It is therefore necessary to change / adjust the refresh rate of the graphics card with his control panel, and set the refresh rate to 60Hz (maximum).
Post edited February 27, 2020 by FlaW313
I had constant crashes as well. I couldn't even look around in the pilot's seat in the beginning of the game without it crashing. I looked around and I ended up finding a fix that worked on my AMD hardware (I have a Sapphire RX 580 8GB, Ryzen 5 2600X, 32GB RAM) : on youtube (look for: How to Fix: Wolfenstein: The New Order Crashing/Performance Issues (AMD) (2017)) . Basically I had to do some registry editing and turn off Catalyst AI. Not the constant crashing is gone, but the load times can be a bit long, and on occasion the game can freeze between loading levels.

While the game with Vsync on is locked pretty much as 20fps, it hits 60 fps with Vsync off and at least it's playable. I just saw that the game got update with a hotfix. I'll download the whole thing again, and see if there are any further improvements.

Funny, I thought if I had a high end GPU that I wouldn't have this problem, but if someone with a 2080ti is having problems then...
So, it still crashes even with the update?
No, The new update has fixed the problem for me.
In order to test whether or not the hoxfix patch solved everything, I undid the previous registry fix, and installed the patched game. I tried loading my savegame in the prologue and the game crashed after a few seconds. When I reapplied the registry fix, the game was still locked at 20fps with all settings on low and vsync on, and ran acceptably with vsync off.

TL:DR The hoxfix patch didn't work for me.

The only patch that seemed to get the game back to normal (meaning I can have vsync on and the fps around 60) was the 'id5 Tweaker.
I've been experiencing the same issue - as per OP's report - with the Steam version of TNO too, and I've never been able to properly fix it. The game doesn't really freeze, as in, if you go to Task Manager - when it gets stuck to a loading screen - and then come back to it, it keeps playing normal. It's super annoying, though, and completely breaks the atmosphere and the engagement, to me.
I've been told it could depend on a multitude of different factors: Nvidia drivers, the fact I play on an MSI gaming laptop (GS63 Stealth 8RE with a GTX 1060), a bug of some sort in the user profile's directory...

Reading @Vonyor last post, I feel kinda tempted to give this GOG version a try, also considered the current discount.
Post edited April 11, 2020 by Galdelico