It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

After installation, while trying to launch the game it closes itself with the error:

Player data archive not found at `/home/***/GOG Games/Wizard of Legend/game/WizardOfLegend_Data/data.unity3d`, using local filesystemsupport/gog_com.shlib: line 94: 28744 Aborted

Sytem: Archlabs (Linux) x64

Update: installed it in Ubuntu in VirtualBox - same error message missing data.unity3d
Post edited June 02, 2018 by Vincent-Reaper
No posts in this topic were marked as the solution yet. If you can help, add your reply
I had the same problem. Do you have any wireless controller driver running like xboxdrv? I've tried like two or three different controllers and with all the game just crashes, as long as the driver is running in the background. When I stopped the service everything worked fine. But of course only with mouse and keyboard. Even with wired controller I had a lot of problems until I started the game with steams third party feature. :/
Well, if that works it might be a temporary workaround.
But it's clearly no sollution and sholud really be fixed.
Could you please verfiy if this workaround works for you? It clearly is no solution, but if we can figure out which component it really is the devs have a better chance to fix it.
Well,I installed it first on a fresh Archlabs system, without any drivers downloaded and got that error. after downloading some drivers, still same error.
Secondly I installed it on my old windows partition, on which it worked, just to rule out hardware issues.
After that I installed it on a fresh Ubuntu virtual machine (so again no aditional drivers) where I again got the same error.
So, I installed Unbuntu 18.04 in a VM and tested it myself. WoL throws the same error in the terminal as already mentioned. I took a look at the logs in ~/.config/unity3d/Contingent99/Wizard of Legend/Player.log and it tells me the following:

Desktop is 1280 x 912 @ 59 Hz
Unable to find a supported OpenGL core profile
Failed to create valid graphics context: please ensure you meet the minimum requirements
E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer
Vulkan detection: 0
No supported renderers found, exiting

I took a look at the version of the OpenGL driver installed, which is version 3.0, too low. On my Arch OS I have 3.2. So it seems that the error with the data.unity3d is just too generic and could be anything. For me on Arch its the xboxdrv. Please take a look at the Player.log and post the result.
Well, don't ask me what I did but now it's only down to the gamepad driver issue you had.
So it's time for the devs now to get their stuff right...
20 days later and not even one answer from the devs, as well as no fix from an update.
That's pretty disapointing and the game therefore a pure waste of money.

I'm definitely going to warn others of putting money into this developer.
post to delete please...
Post edited December 29, 2019 by PowaBanga