It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I'm attempting the play this with a Saitek X52 Pro, and the deadzones on the X- and Y-axes of the stick are so large as to render it unplayable.

Does anyone have a solution to this? The deadzones on the stick are already set up properly, so it's something to do with the game.

Thanks!
No posts in this topic were marked as the solution yet. If you can help, add your reply
[url=][/url][url=][/url]
avatar
tentaclesex: I'm attempting the play this with a Saitek X52 Pro, and the deadzones on the X- and Y-axes of the stick are so large as to render it unplayable.

Does anyone have a solution to this? The deadzones on the stick are already set up properly, so it's something to do with the game.

Thanks!
I don't know if it works or not but it would be nice if GOG could do soemthignsimilar to this for us (or prod dosbox to officially support it)

http://vogons.zetafleet.com/viewtopic.php?t=24832&sid=dffab7b1a14413af6e50ce6f70a345ce
Hi, I wrote this patch and would be happy if GoG or the DosBox team included it in the official release. Not sure how to make that happen though, but the source code changes I made are included in the download so it wouldn't be hard to merge them in if there was enough support. Hope you find this custom build useful anyway.
I don't own this game via gog.com, but I own the original cd and play it with DosBox 0.74. I also own two joysticks - a Saitek ST 290 and a Microsoft Sidewinder Precision Pro. When I play the game with the Saitek, I have the dead zone problem. However, when I use the Sidewinder, I have no dead zone at all.

I don't know why the Sidewinder works, but I hope this might be of some help to someone who wants to play the game with a joystick. I did edit the DosBox config file to prevent cursor drift (changed timed from 'true' to 'false'), but I made no other changes.
avatar
Sidewinder: [url=][/url][url=][/url]
avatar
tentaclesex: I'm attempting the play this with a Saitek X52 Pro, and the deadzones on the X- and Y-axes of the stick are so large as to render it unplayable.

Does anyone have a solution to this? The deadzones on the stick are already set up properly, so it's something to do with the game.

Thanks!
avatar
Sidewinder: I don't know if it works or not but it would be nice if GOG could do soemthignsimilar to this for us (or prod dosbox to officially support it)

http://vogons.zetafleet.com/viewtopic.php?t=24832&sid=dffab7b1a14413af6e50ce6f70a345ce
That improves the stick control by a very large margin. Thank you so much for posting that link.
avatar
tentaclesex: I'm attempting the play this with a Saitek X52 Pro, and the deadzones on the X- and Y-axes of the stick are so large as to render it unplayable.

Does anyone have a solution to this? The deadzones on the stick are already set up properly, so it's something to do with the game.

Thanks!
I know this is an old thread but it may help people with the same problem when looking this up in Google.
The solution for the X52 is rather simple. Go to the Joystick's properties page where you can adjust the deadzones manually. Move the OUTSIDE sliders closer to the centre (I put them roughly in the middle). Leave the inside sliders at the centre. Now the deadzone you experience in dosbox games is much better.
Can anyone help me out with adding dead-zone tweaking to the GOG Wing Commander dosbox .ini? The link that was posted has expired, unfortunately. I'm using a Logitech Extreme 3D Pro, for reference.
Post edited February 03, 2015 by The_Atomik_Punk
avatar
The_Atomik_Punk: Can anyone help me out with adding dead-zone tweaking to the GOG Wing Commander dosbox .ini? The link that was posted has expired, unfortunately. I'm using a Logitech Extreme 3D Pro, for reference.
This is the guy who made the patch http://www.davidwaltersdevelopment.com/tools/dosbox/

Hope it helps
Here's one setting I changed that seemed to help a lot.

Just for reference, I originally tried playing on a Thrustmaster HOTAS X, but the massive dead zone rendered pretty much any game running in DOSBOX unplayable. On a whim, I tried playing with a wired XBOX 360 controller, and was surprised to find that there is little or no dead zone when using it. This suggested to me that the dead zone issue was (partially at least) due to the stick I was using.

Upgrading to a Thrustmaster T.16000M FCS HOTAS improved things greatly for some games (X-Wing and Descent) but did little for others (all the Wing Commander games).

I then tried changing some DOSBOX settings:

Joystick type: FCS
Timed interval: No

I don't think this improves the dead zone, but I think the timed interval setting is required to prevent drifting.

I then set

Emulation core: Normal
CPU Type: 386
CPU cycles: 3500

In my case this DRASTICALLY improved the dead zone for WC1 and 2. It's still there, but instead of covering a full 20-25% of the joystick range, the dead zone now only occupies the initial 5-10% of the range. It's not perfect, but it is very playable.

Finally, I cleared the keyboard mapper and left it off. I found that setting this ended up causing way more problems than it was worth. Better to just play these games the way they were intended, with just a stick, two buttons, and your keyboard for everything else.

Note that WC1 and 2 are not meant to play "smoothly." You can increase cycles in DOSBOX and get the game running extremely smooth, but it messes up all sorts of things. For example, the joystick becomes less responsive (larger dead zone) the faster you force the game to run (actually, my theory the joystick response stays the same, but the game is running smoother so it makes it much more noticeable). I would also encounter all sorts of game balance issues, like hyper aggressive enemies that could take me down in just a couple seconds. My theory is that a lot more than the frame rate is tied to the CPU speed.

Back in the day, playing these on original hardware in DOS, they were not 60 fps by any means. I clearly remember the games being a bit jumpy on my 386 (which was more than powerful enough to run the game). This means that the game will be quite smooth when nothing is going on, but will drop frames during hectic dogfights or when flying through asteroid belts. That's just how the game was back then.

Wing Commander Privateer is a different matter altogether however. I am tempted to just play that one with a mouse.
Post edited June 24, 2017 by newtmonkey
Yeah, at the time not requiring calibration was probably nice, but now we see why not that many developers did that.
avatar
The_Atomik_Punk: Can anyone help me out with adding dead-zone tweaking to the GOG Wing Commander dosbox .ini? The link that was posted has expired, unfortunately. I'm using a Logitech Extreme 3D Pro, for reference.
Download the logitech software for the stick:

http://support.logitech.com/it_it/product/extreme-3d-pro/downloads#

It allows to sed deadzones and mpa the extra buttons.
Post edited June 24, 2017 by Det_Bullock
avatar
newtmonkey: Here's one setting I changed that seemed to help a lot.

Just for reference, I originally tried playing on a Thrustmaster HOTAS X, but the massive dead zone rendered pretty much any game running in DOSBOX unplayable. On a whim, I tried playing with a wired XBOX 360 controller, and was surprised to find that there is little or no dead zone when using it. This suggested to me that the dead zone issue was (partially at least) due to the stick I was using.

Upgrading to a Thrustmaster T.16000M FCS HOTAS improved things greatly for some games (X-Wing and Descent) but did little for others (all the Wing Commander games).

I then tried changing some DOSBOX settings:

Joystick type: FCS
Timed interval: No

I don't think this improves the dead zone, but I think the timed interval setting is required to prevent drifting.

I then set

Emulation core: Normal
CPU Type: 386
CPU cycles: 3500

In my case this DRASTICALLY improved the dead zone for WC1 and 2. It's still there, but instead of covering a full 20-25% of the joystick range, the dead zone now only occupies the initial 5-10% of the range. It's not perfect, but it is very playable.

Finally, I cleared the keyboard mapper and left it off. I found that setting this ended up causing way more problems than it was worth. Better to just play these games the way they were intended, with just a stick, two buttons, and your keyboard for everything else.

Note that WC1 and 2 are not meant to play "smoothly." You can increase cycles in DOSBOX and get the game running extremely smooth, but it messes up all sorts of things. For example, the joystick becomes less responsive (larger dead zone) the faster you force the game to run (actually, my theory the joystick response stays the same, but the game is running smoother so it makes it much more noticeable). I would also encounter all sorts of game balance issues, like hyper aggressive enemies that could take me down in just a couple seconds. My theory is that a lot more than the frame rate is tied to the CPU speed.

Back in the day, playing these on original hardware in DOS, they were not 60 fps by any means. I clearly remember the games being a bit jumpy on my 386 (which was more than powerful enough to run the game). This means that the game will be quite smooth when nothing is going on, but will drop frames during hectic dogfights or when flying through asteroid belts. That's just how the game was back then.

Wing Commander Privateer is a different matter altogether however. I am tempted to just play that one with a mouse.
This also helped me significantly.
I have a different problem – does anyone have a solution for this?

My problem isn’t a deadzone when the stick has no/little deflection, but a retarding behavior when I quickly do a partial or full deflection of the stick like you do during fast dogfights. Sometimes quick stick deflections result in quick ship movements, but in most cases the ship movement is very slow (the same as the stick would have been deflected only slightly) or not happening at all. If I fully deflect the stick to any direction immediately, it often happens that the ship isn’t showing any reaction. It feels like fast deflections are too fast for the system – but they are needed for the dogfights. When I remember playing WC3/4 on my Pentium 5 / MS Dos over 20 years ago, this problem didn’t exist.

Game: Wing Commander 3 from GOG via Dosbox on a Win10 machine
Input devices tested with the same issue: Xbox controller, Saitek/Logitech X52
Logitech keyboard mapping software: I don’t use it as it doesn’t work/match any key to the stick
Antimicro keybord mapping software: I tried it for both input devices but face the same described problem
avatar
Apollo346: I have a different problem – does anyone have a solution for this?

My problem isn’t a deadzone when the stick has no/little deflection, but a retarding behavior when I quickly do a partial or full deflection of the stick like you do during fast dogfights. Sometimes quick stick deflections result in quick ship movements, but in most cases the ship movement is very slow (the same as the stick would have been deflected only slightly) or not happening at all. If I fully deflect the stick to any direction immediately, it often happens that the ship isn’t showing any reaction. It feels like fast deflections are too fast for the system – but they are needed for the dogfights. When I remember playing WC3/4 on my Pentium 5 / MS Dos over 20 years ago, this problem didn’t exist.

Game: Wing Commander 3 from GOG via Dosbox on a Win10 machine
Input devices tested with the same issue: Xbox controller, Saitek/Logitech X52
Logitech keyboard mapping software: I don’t use it as it doesn’t work/match any key to the stick
Antimicro keybord mapping software: I tried it for both input devices but face the same described problem
I'd love for there to be a solution to this as I'm experiencing the same.