It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


yesterday i could heal my units via Spells or eating animals. today this dosnt work anymore i see the speel or the eating animation but no health gain.
No hardware or software changes or updates/patches. nothing changed.
Restart no fix
Reboot no fix
Reinstall no fix

any suggestions?
Hi Pennjor,

First, I'm putting this here as reference, since it's a thread on the same issue:
Healing not working
Since you mention "eating animals", I wonder if you have a Minotaur hero, as was mentioned in that thread?

I still get this occasionally (Win7, WBC3), and rebooting fixes it every time for me, but obviously it hasn't for you, hmm.

One thing I'll suggest: start with a new hero, see if healing works. If so, go back to the previous, and see if healing has come back (there may be something reset by the act of starting a new compaign with a new hero).

Another suggestion: you say you've reinstalled, but that hasn't fixed it. Clearly, however, your reinstall did not clear out all old debris, or this would be impossible. So I would suggest going back to the very old-fashioned method: uninstall. Reboot after uninstalling. Then reinstall. The reboot after uninstalling is not optional!

Even so this won't get rid of every registry entry that might conceivably be screwing up your game, but since you've already gone as far as reinstalling, this is just one step further.

thanks for the reply.

i tell you what happend, after reinstalling and not fixing it, i set everything back to the settings as it was and tried it again still no fix. so i stopped playing and did other stuff. the next weeked there was not much time for gameing, but the weekend after that. strted wbc played a game and it was fixed... again i chaned nothing and it fixed itself ...
i dont know why and how but its fixed