It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I had this game working just fine about six-ish months ago, and suddenly when I boot up now this thing is completely broken. Nothing I do fixes anything, I've reinstalled multiple times, tried all sorts of tricks posted here or on youtube, nothing. Can't get a single mission to work because nothing can even take an action, and even ending the turn does nothing. I need help to figure this out because it was all working FINE prior, no problems at all.

Check that post/thread and the threads linked within.
I tried everything else - all the old fixes, the regedit tweaks, the filename changes, getting previous versions of the game downloadable, etc etc. NADA.

The one thing that fixed it for me?
Going into my graphics card control panel (I've got Nvidia), disabling DSR in the 3d settings, and then going to resolution, and setting a custom resolution for 640x480 (all other settings as default otherwise).
Somehow, that was the one thing that fixed the animation bug, both in Chaos Gate, and in Final Liberation.

If that doesn't work, you'll have to go through the laundry list of previous fixes and compatibility shenanigans :(