It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Was literally playing this just fine the other day. Played it a few times on my laptop at my girls house while she was studying. Now on my desktop it just blinks out and sends me right back to desktop.... tf :( please help
No posts in this topic were marked as the solution yet. If you can help, add your reply
Found out that it was the smackw32.dll causing some sort of crash. deleted that file and then it worked fine.
It is your system security cause that, not hte games dll's.
This file need to play video (smacker video by RAD before bink format and binkw dll). First reinstall game to D:\Games\Warcraft-2\ and turn off DEP (you cantry add Galaxy exe to exceptions and add game to galaxy as a link, installing game from galaxy not required - any exe started from one will get same arguments - adminrun, compatibilities, cpu priority /etc).

Unless, you dont need videos of course...
Post edited December 12, 2022 by QWEEDDYZ
avatar
Gwynoth: Was literally playing this just fine the other day. Played it a few times on my laptop at my girls house while she was studying. Now on my desktop it just blinks out and sends me right back to desktop.... tf :( please help
I just bought this game and it worked on one PC but not on my laptop.
Found disabling that .dll got it going but without video.

So I installed K lite codec pack and rebooted as that .dll is for video.

Now works fine. Not sure what else to suggest.
Hmm... not sure if i ever have installed any codec packs or single codecs... except Indeo Video 5 and WMV 9 but they are not for SMK video.
Maybe i installed CCCP. I didnt install too large K-Lite...

As for issue. It is not about codecs anyway. To play video you already have codec - in that dll. Game crashed on that DLL do a security reasons (dll function blocked). Happen for me too randomly at one point. Didnt changed anything on my Win7, but game stop working. But i didnt turn off DEP.
Not sure if it really 100% better to do that. But Windows not allow set it properly. Default for system apps only not work as it should - it apply literally to every exe (can br seen from task manager). Set i to all exe and added exception (you can do that only set DEP to all apps) also not always work. This feature broken from WinXP up to Win10.
So at one point this is better disable entirely by CMD.exe (manually as admin from system32 folder)
bcedit/ nx off
or something like that (google it for exact command promt)

Keep UAC at default option and use admin run. UAC pop-ups blocking Desktop should appear and ask you about admin permission. This is to make sure it work properly (disabling UAC do not give admin rights to apps), this is still keep protect you when some app you didnt launch ask for admin rights.

Admin run should be enough for Win Defender if game installed in D:\Games\. 3rd party AB should be turned off.

Maybe some else third party app interfer it. Especially with overlays. Analyze Wait chain or ProcessExplorer can help find that app (keep crahsed game and werfault windows and start task manager\process explorer)
Post edited December 14, 2022 by QWEEDDYZ