It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I seem to be having a problem with the brightness. Every time I open up the game it's all dark and I always have to re-adjust it each time.
Why is this happening? How do I fix it?
Are you using a colour profile on your desktop? If so, you may want to create a specific profile for the game, a bit brighter. On my PC at first the game is also too dark because of that. You can guess it's using a customized brightness setting when you change that in the options (it should "jump" to another value, as if the range of values was different - Windows brightness, actually).

Also, try changing other options, quit, and re-launch to check them. If they haven't changed, you may have your config file put into "read only" mode (which prevents modifications). Check if it is so in the properties of "masquerade.ini" in the game's directory.
I don't think any of it is working. Tried some methods and it keeps going back no matter what.
Are there any methods that would probably make it work?
I have an even worse issue, my brightness bar moves alright but doesn't do anything, regardless of whether I get it at the max or min value the brightness stays the same.

The way I get around it is I temporarily change the brightness of the entire desktop from nVidia's Control Panel (the AMD Catalyst app has the same functionality as does the Intel control panel) for the duration of the game, then reset it to the default value.

I would very much like a better solution though as well...
Post edited October 07, 2012 by KeyperOS
avatar
KeyperOS: I have an even worse issue, my brightness bar moves alright but doesn't do anything, regardless of whether I get it at the max or min value the brightness stays the same.

The way I get around it is I temporarily change the brightness of the entire desktop from nVidia's Control Panel (the AMD Catalyst app has the same functionality as does the Intel control panel) for the duration of the game, then reset it to the default value.

I would very much like a better solution though as well...
Try deleting the masquerade.ini file in the game's directory, then restarting the game. It will ask you to configure one last time. After that, restart the game and see if the changes stick.
Nope, the settings were reset but the brightness bar still didn't do a thing.

To clarify, the bar itself will remain in the position/setting where I put it, it's just that it won't DO anything.

Altering the desktop brightness works but of course it works for the entire system.

In case it matters I have Windows 8 x64 with the latest drivers for an nVidia 580 with 1.5GB dedicated GDDR5 RAM but the drivers will also borrow an additional 2.5GB (for a total of 4GB) from the system RAM (I have 12GB).
Hi,

Same problem here, did you finally found a solution ?
Usually the game is dark if you are attempting to run it in window mode. In window mode, the gamma slider will NOT work. You'll have to use your graphics card options to adjust the brightness (nVidia control panel or CCC). In full screen mode, the gamma slider usually works.
Same here, it's unplayable in certain points this way... has anybody figured out a solution?
I'm having the same issue in Windows 10. Windowed or full screen makes no difference. The gamma slider moves but it makes absolutely no difference at all in the game's brightness. The silver mines were nearly impossible to navigate even using a torch. Most areas aren't so bad but some...
Brightness sliders rarely work under 8.1 and 10, because of... well things I don't really get but they may be linked to compatibility settings applied to <Dx9 games (which, as far as I understood, work in a kind of window mode to prevent clashes with the Desktop, so they are tied to its brightness, like the real window mode. Or something.).

You could try wrappers to begin with (dgVoodoo ( http://dege.freeweb.hu/ ), WindeD3D (you may need to alt-tab to regain control), DxWnd maybe, DXGL...) and see if they work for you.

The Age of Redemption Mod ( http://www.e-mods.net/modules/mods/about_aor.php ) should provide options to set the game to Dx9, this may solve the issue right away. It changes the gameplay though (in a good way! - I only got enough to play only half of the game with an older version, sadly, but the latest looks great!). Note that the executable may be different in this case, keep this in mind if you're using the ACT (see below).

There are ways to change/add compatibility fixes though - all of them can also solve a bunch of other issues.

A solution which works well is using the Application Compatibility Toolkit. It's a bit complicated at first, you can have a look at how it works here for example (for ACT 5.6; scroll down to post #66 - http://www.blitzbasic.com/Community/posts.php?topic=99477 ). However it allows for easy testing and changes. The ddraw.dll on this page could also help.

I've made 'installers' using the Homeworld games OpenGL fix from PCGamingWiki: http://1drv.ms/1DSWrDb . I've kept the install/uninstall files, only pointing to my fixes rather than Homeworld's, obviously, so they should work fine.

You may want to make/install these fixes yourself however. Follow the help in the post #66, or if you're using my files, after installing the ACT open the .sdb files and simply go to File=>Install (or right-click on the barrel icon). Uninstalling works this way too. You'll get a "Test application" option which will be of great help. These are the fixes I'm using:

"AllowMaximizedWindowGamma" - it solved the issue under 8.1, under 10 the second option is better.

"DXPrimaryEmulation [with parameter -DisableMaxWindowedMode]" - it's the one from the post above. May help, will also smooth <Dx9 games/16bit graphics but may also introduce flickering videos and interface. Try the third fix in that case.

"NoGDIHWacceleration" - works even better on older games (smooth framerate etc.), but may not work on not-so-old ones. This may also help if you have buggy cutscenes/intros (use it instead or with the bink.dll as indicated in the relevant thread in this forum).

If ACT 5.6 doesn't provide these fixes, search for 8.1 (or W10 according to your OS) Development Kit (ADK) and only download the ACT 6+ (the rest is alien to me ^^' ). Use the 32bit tool by the way.

Edit: changed order after some tests with Windows 10 (game locked on IntelHD, Optimus on my laptop doesn't work as intended right now, I can't try nVidia).
Post edited August 15, 2015 by Darucas
The Information provided by Darucas fixed my issue in Windows 10 with brightness. Specifically the DxPrimaryEmulation fix with the added parameter.

Thank-you! Had never used application compatibility toolkit before, not difficult with the post as a guide.
avatar
crimson_twilight: The Information provided by Darucas fixed my issue in Windows 10 with brightness. Specifically the DxPrimaryEmulation fix with the added parameter.

Thank-you! Had never used application compatibility toolkit before, not difficult with the post as a guide.
I had the same problem and that solution worked for me too, thanks to Darucas!
Using the Compatibility Toolkit fixed the issue for me too (same solution, with the 2 parameters). Thank you so much!
Can confirm, the DxPrimaryEmulation fix worked on my win10 64 bit machine as well. man, how do people even figure this stuff out?