It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I just noticed that GOG's version of Ultima V continues to demonstrate a bug I've seen in the PC version ever since the original CD-ROM compilation of the first six games: When you go to (H)ole up and Camp and the game asks you how many hours, it will only let you press the "5" key (for five hour power naps). You should be able to choose anywhere from one to nine hours.

Anyone else have this problem, and if so, what patches are out there to fix it? I can't seem to find anything about this on Ultima Aiera or in the Codex wiki...
avatar
TheKid965: I just noticed that GOG's version of Ultima V continues to demonstrate a bug I've seen in the PC version ever since the original CD-ROM compilation of the first six games: When you go to (H)ole up and Camp and the game asks you how many hours, it will only let you press the "5" key (for five hour power naps). You should be able to choose anywhere from one to nine hours.

Anyone else have this problem, and if so, what patches are out there to fix it? I can't seem to find anything about this on Ultima Aiera or in the Codex wiki...
Works just fine for me. Are you using the number pad? With numlock on 5 would be the only number not interpreted as an arrow key.
avatar
TheKid965: I just noticed that GOG's version of Ultima V continues to demonstrate a bug I've seen in the PC version ever since the original CD-ROM compilation of the first six games: When you go to (H)ole up and Camp and the game asks you how many hours, it will only let you press the "5" key (for five hour power naps). You should be able to choose anywhere from one to nine hours.

Anyone else have this problem, and if so, what patches are out there to fix it? I can't seem to find anything about this on Ultima Aiera or in the Codex wiki...
avatar
wonko1221: Works just fine for me. Are you using the number pad? With numlock on 5 would be the only number not interpreted as an arrow key.
Nope, it's all done with the top-row number keys, and it makes no difference whether I have Num Lock on or off.
avatar
TheKid965: I just noticed that GOG's version of Ultima V continues to demonstrate a bug I've seen in the PC version ever since the original CD-ROM compilation of the first six games: When you go to (H)ole up and Camp and the game asks you how many hours, it will only let you press the "5" key (for five hour power naps). You should be able to choose anywhere from one to nine hours.

Anyone else have this problem, and if so, what patches are out there to fix it? I can't seem to find anything about this on Ultima Aiera or in the Codex wiki...
I've never ever experienced this with the PC version of Ultima V. Everything works fine for me and always has done. Must be just you.
I believe you need 6 or more hours to actually get rested, so that would be a pretty severe bug. Try the numlock patch maybe? Is there anything else odd about your keyboard?
Actually I have been playing it on a laptop without a number pad and no numlock key. My solution was to go to the electronics store and buy a number pad at $10 which has solved the problem. Use a number pad and/or make sure your system has a numlock key, or the numbers on top will act like a number pad, thus you will go north when pressing 8, etc.
high rated
I just wanted to say that I was finally able to fix this weird bug. The trick is to make sure Num Lock is off before you actually launch the game. Turning it on and off while the game is running will have no effect, but if Num Lock is on before you start the DOSBox session, the game will bug out when entering any digit besides 0 or 5 (not just for camping, but at any other time -- which will render the game unwinnable, since you need to use the numbers at one point to gain a critical plot item, which I'm deliberately leaving vague for those who haven't played yet).

Since I always have Num Lock on out of habit, this was what kept screwing me up.

Just an FYI for those who're having the same or similar problems.
excellent discovery. i've tried all sorts of ways to try get it to work short of breaking my keyboard. and this is the exact solution. bravo!
avatar
TheKid965: I just wanted to say that I was finally able to fix this weird bug. The trick is to make sure Num Lock is off before you actually launch the game. Turning it on and off while the game is running will have no effect, but if Num Lock is on before you start the DOSBox session, the game will bug out when entering any digit besides 0 or 5 (not just for camping, but at any other time -- which will render the game unwinnable, since you need to use the numbers at one point to gain a critical plot item, which I'm deliberately leaving vague for those who haven't played yet).

Since I always have Num Lock on out of habit, this was what kept screwing me up.

Just an FYI for those who're having the same or similar problems.
Post edited October 14, 2011 by ken
I had the same problem, but switching Numlock OFF didn't work for me.

I tried every solution i could find on the internet and finally got it to work - i had to go to language settings in Windows and set English as a default input language. Yeah, i have non-english keyboard and switching with Alt+Shift just doesn't work - I don't know why. You need to set it as default and then DON'T use numeric keyboard in-game.

After that, you can leave Numlock ON and it works even with music upgrade patch.
avatar
TheKid965: The trick is to make sure Num Lock is off before you actually launch the game. Turning it on and off while the game is running will have no effect,
i've had the same issue with caps lock in IV (not that that's a game wrecker or anything...).
Necroing but I just found what may be another way to ensure the game takes into account all numbers on keyboard (I'm using French as default language on an AZERTY keyboard + the Upgrade Patch thanks to the UltimaPatcher tool).

Just go into the 'ULTIMA5' folder, open 'dosboxULTIMA5.conf' and at the line 'keyboardlayout=auto', change 'auto' into 'us' (or 'uk', should work too), and save. On my PC, I can enter all numbers this way (Numpad won't work though).
I found a different solution. I couldn't get the solutions listed here to work on my laptop, even hooking in up a USB keyboard didn't fix this problem. I did discover however, that if you hold the numlock key down and (while holding numlock) press any number, that it would update the DOS box settings and remain working even after unhooking the USB keyboard. Easy!
TheKid965 Thanks for that I helped me
Post edited January 31, 2020 by Rackhhir
avatar
TheKid965: I just wanted to say that I was finally able to fix this weird bug. The trick is to make sure Num Lock is off before you actually launch the game. Turning it on and off while the game is running will have no effect, but if Num Lock is on before you start the DOSBox session, the game will bug out when entering any digit besides 0 or 5 (not just for camping, but at any other time -- which will render the game unwinnable, since you need to use the numbers at one point to gain a critical plot item, which I'm deliberately leaving vague for those who haven't played yet).

Since I always have Num Lock on out of habit, this was what kept screwing me up.

Just an FYI for those who're having the same or similar problems.
Very helpful, thanks!