It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Is there a way to lower the music volume without lowering the sound effects?
Here's my contribution on setting up Ultima Underworld 1-2 music and sound effects:

https://www.gog.com/forum/general/music_and_sound_effects/page1
avatar
NeroConiglio: Is there a way to lower the music volume without lowering the sound effects?
Which game(s) are you talking about, and with what sound sources (e.g. Ultima Underworld using Rolant CM-32L (Munt) for music + sound effects, and Soundblaster for sampled speech)?

If you are using Soundblaster for both music and sound effects, then I don't think there is a way to change the volume balance (as the game has no internal mixer).

If you are using Roland + Soundblaster combo for Ultima Underworld (the most best sounding combination), then all the sound effects, as well as music, is generated by Roland. Soundblaster is used only for the digitized speech during the intro (and where else there is speech in the game, maybe in the ending?). Since the game itself doesn't let you change music/sound effect volumes separately, you can't make Roland music louder or quieter compared to Roland sound effects. The volume balance between music and sound effects is what it is, as intended by the game developers.

But if that UUW intro speech is too quiet compared to the Roland music, then read on.

Ultima Underworld 2 though uses digitized (Soundblaster) sound effects too so there you might want to rebalance the music/sound effects volumes. So what you want to do is to somehow make DOSBox Roland MIDI output quieter, and/or Soundblaster (digitized) louder.

If you are using Munt (Roland MT-32 emulator), are you also using BASSMIDI or VirtualMIDISynth with it, or have you edited dosbox.conf instead to get the correct MIDI output for DOSBox? I'm asking this because it may be BASSMIDI/VMS affect the MIDI output volume as well, IIRC BASSMIDI had a slider for the MIDI output volume, and VMS has some MIDI volume shortcuts explained in the "Shortcuts" tab. But then I don't think BASSMIDI works fully in Windows 8.1 or 10, so BASSMIDI/VMS may be useful only in Windows 7/Vista...

Another way may be using the DOSBox mixer settings. So edit the game's DOSBox config file, and at the end of the file under the [autoexec] section, add a line for MIXER. I don't think it has an option to lower MIDI volume, but it has an option to raise Soundblaster (or master) volume.

https://www.dosbox.com/wiki/MIXER

I tested with it a bit, so if I added e.g. a MIXER line into dosboxULTIMA1_single.conf so that the [autoexec] section looks like this (I added the bolded line), then at least for me the intro speech got louder compared to the Roland MIDI music. I think the mixer setting 100 is the default, so over that makes it louder than the default (also compared to MIDI music).

[autoexec]
# Lines in this section will be run at startup.
cls
mount C ".."
imgmount d "..\game.gog" -t iso -fs iso
d:
cls
MIXER MASTER 150:150
uw.bat
exit
But as said, this changes the volume balance only between sampled and MIDI sounds. In the first Ultima Underworld you can't change the volume balance between other sound effects and the music, as they always come from the same sound device (either the Roland MIDI device (e.g. the Munt emulator), or the Adlib/Soundblaster device emulated by DOSBox).
Post edited June 19, 2016 by timppu
avatar
timppu: cut
I was asking for UUW and I wanted to know if you could lower the music without lowering the in-game sound effects.

Thanks for the clarifications, too bad that nothing can be done but it's not a big deal.
avatar
NeroConiglio: Thanks for the clarifications, too bad that nothing can be done but it's not a big deal.
Yeah... when you play it, sometimes there is slower and quieter music playing so then you probably hear the sound effects (footsteps etc.) better, at least this is the case when using Roland (I haven't played the game with Soundblaster music).

If hearing the sound effects is vital in UUW, then I think the only alternative is to switch off music altogether from the in-game options.
Hello all,

Thanks to everyone for your contributions to this thread. I had previously spent an evening unsuccessfully attempting to get midi support working for Ultima VI. Tonight, I found this thread and despite some misgivings, gave it another shot - and it worked, first try. I'm looking forward to replaying some of these games from my youth with the sort of perks that my childhood self could not afford.
Post edited July 30, 2017 by atteSmythe
avatar
atteSmythe: Hello all,

Thanks to everyone for your contributions to this thread. I had previously spent an evening unsuccessfully attempting to get midi support working for Ultima VI. Tonight, I found this thread and despite some misgivings, gave it another shot - and it worked, first try. I'm looking forward to replaying some of these games from my youth with the sort of perks that my childhood self could not afford.
Can you tell me what you changed to get midi to work for Ultima VI? I've managed to get Munt working with Ultima Underworld, but it seems that no matter what I cannot get Ultima VI to use Munt... I tried setting midiconfig=1 which worked well enough for UU.
avatar
atteSmythe: Hello all,
Thanks to everyone for your contributions to this thread. I had previously spent an evening unsuccessfully attempting to get midi support working for Ultima VI. Tonight, I found this thread and despite some misgivings, gave it another shot - and it worked, first try. I'm looking forward to replaying some of these games from my youth with the sort of perks that my childhood self could not afford.
avatar
mchartman: Can you tell me what you changed to get midi to work for Ultima VI? I've managed to get Munt working with Ultima Underworld, but it seems that no matter what I cannot get Ultima VI to use Munt... I tried setting midiconfig=1 which worked well enough for UU.
It's been a little while now, but I believe it was starting with this post, #88, that got me on the right track:
avatar
Arkose: Ultima Patcher can be used to set up MT-32 support. Try that and see how it goes.
That patcher is pretty magical