It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I found this utility here (http://membres.multimania.fr/xenerkes/download.htm) that gives you a menu through which you can open all the Ultima games. So anyway, for the filepaths for the launcher to use, I used the shortcuts to the games provided upon installation of the GOG versions of the games, but when I then try to open them through the launcher menu, it just opens DOSBox, and not the games. And when I tried to set the filepath to be straight to the games themselves, that doesn't work either because I need DOSBox to run them.
What can I do to set it up so that I can run the games through the launcher without needing to use a command line or anything?
I think the best way to go would be to create .bat files that would automatically open DOSBox and then have it open the games (and fullscreen it) and link the launcher to those, but I don't know how to do that.
This question / problem has been solved by VisElEchNonimage
Well, I installed Ultima 1 and attempted to use the launcher several different ways:


1. I tried to point directly at the shortcut = The specified file was not found

2. I tried to put the full DosBox command (including -conf etc.) into the game path and then copied the "dosboxULTIMA1.conf" file to the DosBox folder and edited it so that it would point at the correct folder = The specified file was not found

3. I created a batch file to run DosBox with the config file I modified = Command window briefly opens and then exits, something about it not being a valid command

4. I got the bright idea to move the batch file to the same drive as my Ultima install and then remove the (now redundant) drive change = SUCCESS!

I'll compress the batch file, along with instructions on what needs editing in the config file, and upload it somewhere for you in a bit.
avatar
VisElEchNon: Well, I installed Ultima 1 and attempted to use the launcher several different ways:


1. I tried to point directly at the shortcut = The specified file was not found

2. I tried to put the full DosBox command (including -conf etc.) into the game path and then copied the "dosboxULTIMA1.conf" file to the DosBox folder and edited it so that it would point at the correct folder = The specified file was not found

3. I created a batch file to run DosBox with the config file I modified = Command window briefly opens and then exits, something about it not being a valid command

4. I got the bright idea to move the batch file to the same drive as my Ultima install and then remove the (now redundant) drive change = SUCCESS!

I'll compress the batch file, along with instructions on what needs editing in the config file, and upload it somewhere for you in a bit.
Thank you. This will work with all the games, not just I?
Post edited June 19, 2012 by cnaltman62
avatar
cnaltman62: Thank you. This will work with all the games, not just I?
Yep, I created batch files for all the games. My batch files won't work for you unless you have the games installed in the exact same folders I do though so you'll have to do a bit of editing. My installation file will explain it to you, but if you have any questions feel free to let me know.

As of this moment I still haven't gotten it archived but I'll get it done within a few hours at most.
avatar
cnaltman62: Thank you. This will work with all the games, not just I?
avatar
VisElEchNon: Yep, I created batch files for all the games. My batch files won't work for you unless you have the games installed in the exact same folders I do though so you'll have to do a bit of editing. My installation file will explain it to you, but if you have any questions feel free to let me know.

As of this moment I still haven't gotten it archived but I'll get it done within a few hours at most.
I have all the games installed in the default directories (ex.: C:\Program Files (x86)\GOG.com\Ultima Trilogy\Ultima1). So unless you installed somewhere different, we're golden.
lol Yeah, I definitely have them in a different folder. Seeing as I only installed the games to test this though it's not a big deal to re-install them elsewhere (such as the default locations.)
avatar
VisElEchNon: lol Yeah, I definitely have them in a different folder. Seeing as I only installed the games to test this though it's not a big deal to re-install them elsewhere (such as the default locations.)
Well, given that this thread will also be useful for anyone else down the line who wants to use the Launcher with these games, it would be prudent to use the default locations anyway.
avatar
cnaltman62: Well, given that this thread will also be useful for anyone else down the line who wants to use the Launcher with these games, it would be prudent to use the default locations anyway.
I was actually thinking the same thing. Unfortunately, I wasn't thinking that far ahead when I decided to do the first install... :/
avatar
cnaltman62: Well, given that this thread will also be useful for anyone else down the line who wants to use the Launcher with these games, it would be prudent to use the default locations anyway.
avatar
VisElEchNon: I was actually thinking the same thing. Unfortunately, I wasn't thinking that far ahead when I decided to do the first install... :/
I've made similar mistakes myself, believe me... Especially with my last computer: I would save everything in places that made sense at the time, without thinking of where they'd be easy to find later on. And yeah, I ended up forgetting where certain important files were.
And now I'm drifting off-topic.
Post edited June 19, 2012 by cnaltman62
Okay, it's up, it's ugly, it works. I'll get it into a form that's a bit more aesthetically pleasing later but I wanted to get the files accessible for you/everyone at some point before the end of time.

How to use Xenerkes Dragon's Ultima Launcher with GoG.com releases

How to use Xenerkes Dragon's Ultima Launcher with GoG.com releases (Mirror)

EDIT::
The mirror no longer works and I haven't created a replacement yet.
Post edited September 02, 2013 by VisElEchNon
avatar
VisElEchNon: Okay, it's up, it's ugly, it works. I'll get it into a form that's a bit more aesthetically pleasing later but I wanted to get the files accessible for you/everyone at some point before the end of time.

How to use Xenerkes Dragon's Ultima Launcher with GoG.com releases
Will try these out now, and if it works, we're golden!
Followed your instructions to the letter, but only Ultima I and Ultima IV work correctly (it may be worth noting that I'm also playing them all patched with Pix's Ultima Patcher, which automatically applies all the fan-made patches to the GOG versions of the games, like the Ultima IV VGA Graphics Patch). Here's a log of what happens when I try to run all of them:

I: Works fine.
II: Stupidly fast (when I try to use the launcher's built in MoSlo, it says the OS "denied access to the specified file"), and when I try to create a character it gives me the "not a blank player disk" screen.
III: DOSBox Opens, then immediately closes.
IV: Works fine.
V: Divide by 0 error.
VI: "Drive C is mounted as local directory" and then nothing happens.
VII: DOSBox opens, flashes a bit, then closes.
VII Part 2: Opening cinematic plays, then it closes.
VIII: DOSBox opens, then immediately closes.
Underworld: DOSBox opens, then immediately closes.
Underworld II: DOSBox opens, then immediately closes.
The Savage Empire: DOSBox opens, then immediately closes.
Martian Dreams: DOSBox opens, then immediately closes.
Post edited June 20, 2012 by cnaltman62
avatar
cnaltman62: Followed your instructions to the letter, but only Ultima I and Ultima IV work correctly (it may be worth noting that I'm also playing them all patched with Pix's Ultima Patcher, which automatically applies all the fan-made patches to the GOG versions of the games, like the Ultima IV VGA Graphics Patch). Here's a log of what happens when I try to run all of them:

I: Works fine.
II: Stupidly fast (when I try to use the launcher's built in MoSlo, it says the OS "denied access to the specified file"), and when I try to create a character it gives me the "not a blank player disk" screen.
III: DOSBox Opens, then immediately closes.
IV: Works fine.
V: Divide by 0 error.
VI: "Drive C is mounted as local directory" and then nothing happens.
VII: DOSBox opens, flashes a bit, then closes.
VII Part 2: Opening cinematic plays, then it closes.
VIII: DOSBox opens, then immediately closes.
Underworld: DOSBox opens, then immediately closes.
Underworld II: DOSBox opens, then immediately closes.
The Savage Empire: DOSBox opens, then immediately closes.
Martian Dreams: DOSBox opens, then immediately closes.
/me whistles...

Well then... lets get some info and we can start debugging and posting fixes shall we?
Ultima Trilogy is installed to "C:\Program Files (x86)\GOG.com\Ultima Trilogy", I assume, for the simple fact that Ultima I works for you.

I applied the patches using Pix's patcher as well so I could test them and U3 crashed on me, but everything else worked perfectly.* As for U3 crashing, I have an idea as to what's causing that but I don't have time to look into it right this second.

Let me know where the rest of your games are installed (I know you said it's the default, and I believe you, I just want to concretely rule out problems.) Also let me know where you put the config files and batch files.

I'll check back in the morning after I've tested my hypothesis on U3.

*Actually no, a lot of the games ran stupidly fast as you mentioned. I have ideas there too, and they're related to what I think is wrong with U3 (wrong file being called after applying the patches.)
Post edited June 20, 2012 by VisElEchNon
Okay, here's where all the games are installed:

I: C:\Program Files (x86)\GOG.com\Ultima Trilogy\Ultima1
II: C:\Program Files (x86)\GOG.com\Ultima Trilogy\Ultima2
III: C:\Program Files (x86)\GOG.com\Ultima Trilogy\Ultima3
DOSBox for I-III: C:\Program Files (x86)\GOG.com\Ultima Trilogy\DOSBOX
IV: C:\Program Files (x86)\GOG.com\Ultima Second Trilogy\ULTIMA4
V: C:\Program Files (x86)\GOG.com\Ultima Second Trilogy\ULTIMA5
VI: C:\Program Files (x86)\GOG.com\Ultima Second Trilogy\ULTIMA6
DOSBox for IV-VI: C:\Program Files (x86)\GOG.com\Ultima Second Trilogy\DOSBOX
VII: C:\Program Files (x86)\GOG.com\The Complete Ultima VII\Ultima7
VII Part 2: C:\Program Files (x86)\GOG.com\The Complete Ultima VII\Serpent
DOSBox for VII (Parts 1 and 2): C:\Program Files (x86)\GOG.com\The Complete Ultima VII\DOSBOX
VIII: C:\Program Files (x86)\GOG.com\Ultima VIII - Pagan
DOSBox for VIII: C:\Program Files (x86)\GOG.com\Ultima VIII - Pagan\DOSBOX
Underworld: C:\Program Files (x86)\GOG.com\Ultima Underworld 1 and 2 (game data files in subfolder \UNDEROM1)
Underworld II: C:\Program Files (x86)\GOG.com\Ultima Underworld 1 and 2 (game data files in subfolder \UNDEROM2)
DOSBox for Underworld I and II: C:\Program Files (x86)\GOG.com\Ultima Underworld 1 and 2\DOSBOX
The Savage Empire: C:\Program Files (x86)\GOG.com\The Savage Empire
DOSBox for Savage Empire: C:\Program Files (x86)\GOG.com\The Savage Empire\DOSBOX
Martian Dreams: C:\Program Files (x86)\GOG.com\Martian Dreams
DOSBox for Martian Dreams: C:\Program Files (x86)\GOG.com\Martian Dreams\DOSBOX

I stuck the Batch files in the root of my hard drive. The location of them is just C:\
As in (for example), the .bat for Ultima I is located at C:\Ultima1.bat
Post edited June 20, 2012 by cnaltman62
avatar
cnaltman62: Okay, here's where all the games are installed:

I: C:\Program Files (x86)\GOG.com\Ultima Trilogy\Ultima1
...

I stuck the Batch files in the root of my hard drive. The location of them is just C:\
As in (for example), the .bat for Ultima I is located at C:\Ultima1.bat
Okay, what about the "dosboxULTIMA#.config" and "dosboxMARTIAN.config" etc. files? Did you download those as well and place them into the "DOSBOX" folders? If you just copied them from the original locations then it won't work. I looked at my wording on the page, and it's a bit confusing, so that's my fault. U2 and 3 are still problematic and both UW games run way too damn fast, so I'll check into those and post alternate config files on the page.
Post edited June 20, 2012 by VisElEchNon