It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I'll continue looking into it then... >:(
avatar
VisElEchNon: I'll continue looking into it then... >:(
Sorry to make you go through all this trouble. I wish I could figure this out on my own, but I just don't entirely know what I'm doing.
For now, I'll set up the new configs. ...Agh, I can't download the new ones; your page seems to be down at the moment.
Post edited June 20, 2012 by cnaltman62
avatar
VisElEchNon: I'll continue looking into it then... >:(
avatar
cnaltman62: Sorry to make you go through all this trouble. I wish I could figure this out on my own, but I just don't entirely know what I'm doing.
For now, I'll set up the new configs. ...Agh, I can't download the new ones; your page seems to be down at the moment.
Don't worry about it. I'm just pissed because I actually have no sound at all.

I don't know what's going on accessing my page. I got to it just now so maybe you tried while I was updating the index page?

Okay, I think I've narrowed down the problem (yet another screw up on my part): I mounted the C drive incorrectly for both UW games. I'll get them updated on the page and hopefully things will be good now... (please, please, please)

They're all updated now (in the standard, speed, and complete packages), let's hope this works.
Post edited June 20, 2012 by VisElEchNon
I can't get to the page.

"Firefox can't find the server at rptools-files.co.cc." is the error message I keep getting.
The new versions work perfectly. I'll mark your original link to your page as the solution and leave this thread for posterity.
Excellent! I'm glad we got all the bugs worked out. Now to polish the site. :)

Something is seriously wrong with the domain. I'm gonna set up a mirror and post it in a bit.

Alright, here's the mirror: How to use Xenerkes Dragon's Ultima Launcher with GoG.com releases (Mirror)

Hopefully the original will get sorted out eventually as well.
Post edited June 21, 2012 by VisElEchNon
Hopefully we'll eventually get IX--and maybe Akalabeth*--on GOG, too.
Some minor things are bugging me about the Launcher, though. Namely a few naming errors and a minor aesthetic bug. I just wonder if Xenerkesdragon will ever go back and fix these:
The Launcher refers to them as the "Ages of Darkness/Enlightenment" plural, when the official trilogy titles are "The Age of Darkness/Enlightenment" singular (and with a "the"). He also uses the phrase "Ages of the Guardian," when it's really "The Age of Apocalypse." And why does Akalabeth say "Ultima Akalabeth," when "Ultima" was never officially part of the title (it should just be "Akalabeth")?
But the big one, the actual bug, pops up if you have the option to "Display Available" active, so that the images for the games you don't have are dimmed. The problem is that if you have Martian Dreams, then the dim fades from the image for Ultima Online, too.
Even if these are never fixed, the Launcher functions perfectly, so everything's good. Really, I'm probably just displacing my frustration with Ultima III's difficulty level by complaining about something only marginally related.

*Even if we don't get Akalabeth on GOG, it is technically abandonware. I found it here ( http://www.hotud.org/component/remository/func-startdown/17179/ ), but I don't know how to make it autorun in DOS Box, or work in the Ultima Launcher. Hm.
Post edited June 29, 2012 by cnaltman62
avatar
cnaltman62: *Even if we don't get Akalabeth on GOG, it is technically abandonware. I found it here ( http://www.hotud.org/component/remository/func-startdown/17179/ ), but I don't know how to make it autorun in DOS Box, or work in the Ultima Launcher. Hm.
/me shudders...
Urrrg... the DOS "port" of Akalabeth. You're better off finding an Apple ][ emulator and the original version of the game (yeah... not legal, can't really help you out there...) It's not a pretty game regardless of how you play it, so you might as well get the actual experience versus the remake. The DOS dungeons, for me at least, have always been randomly generated every time you enter them. That is one hell of a game-breaker to me. If anyone knows how to fix that issue though, then it might be worthwhile to play the slightly enhanced DOS version.
avatar
VisElEchNon: ....You're better off finding an Apple ][ emulator and the original version of the game (yeah... not legal, can't really help you out there...) It's not a pretty game regardless of how you play it, so you might as well get the actual experience versus the remake. The DOS dungeons, for me at least, have always been randomly generated every time you enter them. That is one hell of a game-breaker to me....
I really don't want to get another emulator for just one game. And I can deal with the changing dungeons, since I have fun mapping these things out.
Post edited June 30, 2012 by cnaltman62
avatar
cnaltman62: I really don't want to get another emulator for just one game. And I can deal with the changing dungeons, since I have fun mapping these things out.
LOL Every time you enter the dungeon though? It's never the same twice from my experience. :) I do understand about not wanting a second emulator though.
Post edited June 30, 2012 by VisElEchNon
It's also worth pointing out that the DOS version of Ultima I had a very different bug in its dungeon generation, and it's the version that most people play!
The dungeons are supposed to be completely random, like in Akalabeth (the Apple version) and Ultima II. But they--due to this bug--always generate as straight hallways with doors along either side. Turns in the hallways only exist when there are barriers.
This makes the dungeons far more simple than they were supposed to be.
avatar
cnaltman62: It's also worth pointing out that the DOS version of Ultima I had a very different bug in its dungeon generation, and it's the version that most people play!
The dungeons are supposed to be completely random, like in Akalabeth (the Apple version) and Ultima II. But they--due to this bug--always generate as straight hallways with doors along either side. Turns in the hallways only exist when there are barriers.
This makes the dungeons far more simple than they were supposed to be.
Interesting, I never noticed that during my playthrough of U1...
Anyway, I do hope we can get IX and Akalabeth (hell, maybe Online, too) soon-ish.
And as stated, I'm wondering if Xenerkesdragon will ever update his launcher again to fix those (minor) issues.
avatar
cnaltman62: Anyway, I do hope we can get IX and Akalabeth (hell, maybe Online, too) soon-ish.
And as stated, I'm wondering if Xenerkesdragon will ever update his launcher again to fix those (minor) issues.
I've been trying to get into contact with Xenerkes Dragon to see about mirroring the Ultima Launcher files on my page. I still haven't heard anything so I'm afraid the launcher may be in it's final form.
avatar
cnaltman62: Anyway, I do hope we can get IX and Akalabeth (hell, maybe Online, too) soon-ish.
And as stated, I'm wondering if Xenerkesdragon will ever update his launcher again to fix those (minor) issues.
avatar
VisElEchNon: I've been trying to get into contact with Xenerkes Dragon to see about mirroring the Ultima Launcher files on my page. I still haven't heard anything so I'm afraid the launcher may be in it's final form.
That's unfortunate. Ah well, at least we have what we have, and this is here for whoever else needs it later.
Post edited July 01, 2012 by cnaltman62