It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi, and first of all thanks for these awesome games!!

One issue while playing Martian Dreams, at some point it doesn't allow me to save anymore, the game just freezes, no response to any keyboard input.

Sorry if this topic has been covered already but I didn't find anything related here. Does anybody experience the same and have a clue or solution?

thank you!


edit: fooled around with the game a little more. it freezes not only when trying to save, also any action, such as using an object can cause it to crash, but it didn't happen in the first half hour or so of playing, only afterwards. memory issue?
Post edited July 01, 2012 by hildebertborg
No posts in this topic were marked as the solution yet. If you can help, add your reply
Do you have the game installed outside of C:\Program Files? Are you running it as administrator?
I have the same issue with the game. I reach the 1893 landing site and can't save after that without the game freezing.
I've tried multiple solutions, including installing it on other computers and copying the saves over but nothing works.
So my best guess is that the save somehow got corrupted.
Is this a known issue?
I also haveing this problem as well but this happens when any time i try to save the game.
Never had the issue with Martian Dreams but I did have a similar crash when being resurrected in Savage Empire, but only then for some reason but it seems changing the CPU setting in the DOSbox config cleared that up for now.
I have the same problem. The saving worked fine for the first 30 min or so, but after I got back to the beginning saving freezes the game. Sometimes it works, but usually saving kills it. DCT what did you do to fix it?
Try editing the dosbox .conf file in the game's folder and change the "cyclees=" line under the "[cpu]" tag to something like 5000. See if that affects the save freezing. It shouldn't make a difference with SE/MD, but sometimes weird interactions occur regardless.
I am also running into this issue. Like the first poster stated, after playing for about a half hour, the game freezes when saving and also occasionally when doing other things such as wandering through the wilderness (it does not appear to be completely random as it always freezes in the same spot). The music continues to play, however the game stops responding to any kind of input whether keyboard or mouse. I run the game in administrator and I have tried changing the cpu cycles as suggested and neither have an impact. I do have the game installed in a different folder other than c:\program files. Any help would be appreciated, as right now the game is unplayable. Thanks in advance.
It's possible you could just be running into 'combat.' These games are actually turn-based, so you won't be able to move while enemies are taking their turns, even if they are currently offscreen. Martian Dreams is especially bad about spawning wave after wave of enemies as you wander the wilderness, so it can get really bogged down sometimes.
Thank you. Unfortunately, that is not the solution. The music does not change and the combat toggle does not switch on. The mouse cursor also freezes. I left the game running for some time to see if maybe it was just taking some time to load up combat, but it still stayed frozen. I do appreciate the suggestion though!
I had the same problem. I saw a post on the Dosbox Vogons forums where someone had the issue, and someone mentioned doing things in a different order and having Diggs join. So what I did, is I only talked to Garret in the space capsule and got the prybar. I didn't get anything else. Then I used the prybar on the door, answered the copy protection, and went straight to the 1893 landing site. Then I had Diggs join, and started saving there. And amazingly, saving's been working ever since. Hopefully it'll keep working until the end of the game. I don't know if my solution will work for anyone else, but thought it was worth mentioning.
I've run into this save bug too. Anyone knows how to get by it?
I have a theory, if anyone wants to give it a try. As far as I can tell, the savegame seems to reliably corrupt itself if one saves in the area north of 31°15'S and east of 158°00'E unless one had previously saved in the area south of 31°00'S and east of 158°00'E at least once some time before that.

Once the savegame has become corrupted, the game will freeze upon the third time the game is saved following the corruption, again unless one saves in the area south of 31°00'S and east of 158°00'E before the third save. The third save after a corruption won't complete regardless of location. Once the game has been saved south of 31°00'S and east of 158°00'E at least once, further saves don't seem to cause any further problems (for me at least).

Can somebody else with the game installed corroborate the above? I assume the corrupting area also has eastern and northern boundaries, but I didn't bother looking for them. On a sidenote, as Dibbs is located at 31°00'S, it also seems plausible to me that a lot of people would save south of 31°00'S after getting him, possibly explaining why many people report completing the game without ever encountering the issue.
I've managed to complete the game now, and I simply did not save whenever I had to go to the 1893 landing site, but only after I'd gone far away from it (to the other landing site, to Calamity Jane's trading post, or such). The only plot-critical things to get from the 1893 landing site are Dibbs, a weed sprayer (though I think you can find a similar object elsewhere on Mars), and the loose strap from the fuel container. I'm not sure if the loose strap is immediately available, or only becomes so after getting the mission to get the fuel (after delivering the ore for the cannon). Also, the strap seems to contain a bug on its own, the game seems to crash if you use the Look command on it. So don't look at it, just take it to Roosevelt.

It's at least a good thing that the save bug is found early on, it would be frustrating to discover it late in the game and having to start all over.
Post edited December 13, 2015 by Fredde
Just thought I'd add my experience with the game, in the hope it might help others:

- I experienced the freezing bug when trying to save after playing for about 30-60 minutes. Every time I tried to save the game would hang during the save process (although the music would continue to play). I was then unable to successfully restore the game and as there is only one save slot that brought progress to a halt.

- I re-installed the game, and after doing some googling, I avoided saving anywhere near the 1893 crash site where you meet Dibbs. This time I was able to complete the game without experiencing any freezes or bugs of any kind.

My advice:
- When you start the game: do what you need to do to get out of the capsule. Then travel to the 1893 crash site, speak to Dibbs and get him to join your party. DON'T save until you are far away from that location.

- The single save is located at (wherever your gog games folder is located)\Martian Dreams\MARTIAN\SAVEGAMES.
- At the end of each session playing the game I would save a copy of the "SAVEGAMES" folder, so that if my save became corrupted I would only lose the progress of the current session (it took me about 28 hours to complete so you don't to risk losing all your progress).

Best of luck to anyone playing this game - it's well worth the effort!