It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

in the original version of akalabeth Lord British will give me a task when I do it and return he just says "go now complete thy quest" or "I want you to kill a(n) but won't tell me what it is. I tried doing this as a Lizard man and he wouldn't even give me the first quest I tried doing it as a human and he only gives the first then his dialogue is messed up when I return and he just says "go now complete thy quest" or some crap. I am assuming this is a glitch that was never fixed, but if no one gets a quest since the 1979 title was released why would anyone play this game?
Post edited June 14, 2015 by neosapian
This question / problem has been solved by dr.schliemannimage
I also have this problem, after receiving the initial quest and killing the appropriate monster. I return to the castle only to be told go now and complete thy quest? why
It's a bug of the port distributed on GOG. Go , download [url=]the updated game .exe and replace the original one with this.

Another solution is playing the official release of the game, which you can find among the game goodies, named "Akalabeth 1998". - 404 Not Found :(
I found in an old backup folder I had the updated files of the unofficial port:!ZPgUmSiA!jDxESeCG-__fZMD8r6xIpErS7KEev0UD-uxcwtFspjM

It contains both the .bas file and the compiled .exe, so the only thing that needs to be done is replace the ones GOG provides.
Post edited July 18, 2019 by Ghildrean
This is still an issue and I had to use the same fix. Jesus Christ, GOG.
Seriously.. I tried for many many hours to "go now complete thy quest" which I thought meant to "find and kill Mondain" somwhere in the labyrinth. Tried to delve as deep as possible in all different dungeons thinking he was at some random location in a random dungeon. So it was all a bug and all that searching was for nothing and just a bug.. Thanks GoG for that ! :O. Booted up the official release and it worked as intended. Looked nicer also and even had sound !
Post edited May 07, 2022 by VaragtP