It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
You would need
The Two Worlds 2 Velvet Edition
The World merge walkthrough for the reference guide
https://gamefaqs.gamespot.com/pc/944162-two-worlds-ii/faqs/73181
and the 1.4a worldmerge program which is easy to find simply by searching for it.

The walkthrough has directions for setting everything up.

NOTE: 1

All you require is the original Two Worlds 2 game (PC) and
the corresponding Pirates of the Flying Fortress expansion
(which automatically patches your game to vanilla version
1.3). It is advisable, though not required, to use an English
language installation.

NOTE: 2

Two Worlds II Epic Edition includes the original Two Worlds II, the Pirates of the Flying Fortress expansion, and Two Worlds II: Castle Defense.
Post edited March 25, 2024 by Keith_I2