It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello. I've been trying to get Two Worlds: Epic Edition working on my laptop. I can manage to get to the main menu, but as soon as it renders the first frame of the main menu it freezes completely, requiring me to Ctrl-Alt-Del and sign out of my profile entirely to close it. I can't get the Task Manager to appear over the window.

I have tried these versions of PhysX Legacy software:

1. Whatever was included with the installer.
2. Version 9.12.0613
3. Version 9.12.1031

And so far, no luck. Since my laptop uses Intel Iris 655 graphics and not an Nvidia card, so I went ahead and also tried out the .exe marked RADEON, but also no luck.

So in other words, I've tried many of the community fixes already out there and haven't found success. I'll list my laptop's model/specs below just in case some of you have experience something similar:

Macbook Pro 13, 2019 model, running Win10 through Bootcamp.
CPU: i5-8279U
RAM: 16 GB
GPU Intel Iris 655 Graphics

Anyone have any ideas?
No posts in this topic were marked as the solution yet. If you can help, add your reply