It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi there!

When I run Tropico 2 it starts fine, I select the tutorial or a new game, the animation runs and then when I see the Tropico 2 logo (and the game loads the actual level) it crashes unceremoniously into Windows again.

The only message given is that "this program has stopped working".

I got the Tropico Reloaded pack on GOG, which includes Tropico and Tropico 2; now Tropico runs fine (although it won't allow hardware 3D acceleration, because it claims I do not have the DirectX 7 drivers and 16MB of video RAM (the former is probably true, but that's neither here nor there.


Windows 8
DirectX 9c/10/11

To add to this, if I run the Tropico 2 safe mode.bat (i.e. run the game with the safe mode .ini file) it works and doesn't crash.

There is some setting that is upsetting my system, but I'm not sure which, yet. But at least it runs.
In conclusion, I reckon the Tropico Reloaded games (Tropico and Tropico 2) just do not play well with my 3D drivers, neither game works with the 3D driver enabled and Tropico 2 simply crashes if the .ini is set wrong (the safe.ini works, I just copied the settings from that and used in the normal .ini)

Tropico 2 also crashes in-game if I try to enable 3D rendering, while Tropico only scolded me for not having DirectX 7.

I do have DirectX 9c installed, which should be backwards compatable, but for some reason it is not working for me in this case.
high rated
I know this is an old thread,but it might be useful for someone one day. Found this solution on steam discussions.
Go to your installation folder,open tropico2.ini and under [DDraw] change SoftwareDevice from 0 to 1. Tried this on Windows 8.1 64 bit with all ati hardware and it works.
Well thank you ElWrobel for the solution, i had the same problem and just changing SoftwareDevice to 1 doesnt make it crash anymore :)

Windows 8.1 Update 1 64-Bit
Thank you for the solution. Had the same problem on Win 7 64x, now solved. This needs to be pinned on store screen for any new buyer to know what to do.
The solution works for me on win10 64bit as well. Thanks to ElWrobel, and GOG should really pin that on the games detail page....