It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
S-a-y: Actually it not works for me. I created new Runic account, which let mi go in game to create internet game, however when I restarted game, it won't let me log in again, because account is not connected with purchased game/not registered. Any suggestions?
S-a-y

If your location is correct, maybe, really just maybe, did you use non-latin characters in your username?

If so, try to change to only latin bases characters, sometimes this causes problems. Also sometimes certain special symbols might cause problems as well (like @! or similar and talking only about username/charactername NOT password ;) )
avatar
S-a-y: Actually it not works for me. I created new Runic account, which let mi go in game to create internet game, however when I restarted game, it won't let me log in again, because account is not connected with purchased game/not registered. Any suggestions?
avatar
Goodaltgamer: S-a-y

If your location is correct, maybe, really just maybe, did you use non-latin characters in your username?

If so, try to change to only latin bases characters, sometimes this causes problems. Also sometimes certain special symbols might cause problems as well (like @! or similar and talking only about username/charactername NOT password ;) )
I do not have non-latin characters, however I used czech localization for game. I switched back to english and it works (but I cannot customize that ugly fonts).
I owned the game purchased in steam. Claimed it in GOG and I had the same problem with the registration. The game does not detect the purchase/registration.
But not tried again, maybe now it works. Just uninstalled and keep the steam version for now.
Bought it on GOG and created a Runic account that lets me login just fine on their website. Logging in in the game though results in Account not associated with purchase. I am using the username of my Runic account too so I don't know what could be going wrong. Any help would be really appreciated.
Okay, created a new account and the difference between this and the old one is that the username didn't contain any hyphens in the new one. Logged in successfully with this account.