It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hey guys, I think we should gather information about the working / not working mods.
I will check up the thread and update the list every few hours.

Diablo 3 font and GUI - working
Emberfiend v.2.3 - working
Gender Mod - working
Jarcho's Class Compilation v1.3 - working
SSS Torchlight Texture Project v1.31 - working
The Merchant Pack - working


Darnified automap - partially working ( will crash after a certain time - quicksave!)
Paladin_07 - partially working ( no Ferret )
TL2 pets - partially working ( no TL1 ferret )
Reat's Hardcore Supermod Overhaul - partially working ( will crash after a certain time - quicksave!)
SSS's HR retexture pack - partially working ( will crash after a certain time - quicksave!)


Multiplayermod (tlmp_r212) - not working
work ZZ_DFB_Pet_mod - not working
Post edited July 17, 2012 by MoaddinFM
I was able to get the Paladin 07 mod to run , but the ferret pet was not there. Removed the mod and the ferret was back.
avatar
rwelkins: I was able to get the Paladin 07 mod to run , but the ferret pet was not there. Removed the mod and the ferret was back.
Is the mod working w/o the ferret? Did you try?
Paladin_07 works without the ferret option. Did a couple of quest and was able to level her no problems.
avatar
rwelkins: I was able to get the Paladin 07 mod to run , but the ferret pet was not there. Removed the mod and the ferret was back.
avatar
MoaddinFM: Is the mod working w/o the ferret? Did you try?
I cant get this mod to work ZZ_DFB_Pet_mod
Post edited July 11, 2012 by rwelkins
I tried these:
Paladin 07 - works, but no ferret.
Diablo 3 font and GUI (two mods at once - works)
TL2 pets - works, but no TL1 ferret. However, TL2 ferret appears to be identical (at least on the title screen).
Gender Mod works.
SSS Torchlight Texture Project v1.31 - works fine and looks great!
Jarcho's Class Compilation v1.3 - works fine and adds 12 new classes and tons of new pets (cat, dog & ferret still work)
avatar
rwelkins: I was able to get the Paladin 07 mod to run , but the ferret pet was not there. Removed the mod and the ferret was back.
Some modes provides their own pet data, which can or cannot include the Ferret :
Since any mod-provided version of this file overrides the Torchlight default one, I am not sure that we can say that it is a bug.
Post edited July 11, 2012 by Elnareen
I went ahead and stickied this for you, guys, so y'all can have a nice list of mods without having to go deep forum diving. :D

Enjoy the game!
Post edited July 11, 2012 by JudasIscariot
I can report with delight that the mod "Emberfiend" v.2.3 seem to work!
Multiplayermod (tlmp_r212) is still not working after the patch!
The only version of this mod I can find says it is for steam only??
avatar
begolf00: Multiplayermod (tlmp_r212) is still not working after the patch!
avatar
begolf00: Multiplayermod (tlmp_r212) is still not working after the patch!
That is correct, it only works for the Steam version for now. :(
If I had the programming talent I'd make a universal one myself.... hey, maybe runic could kickstart one! I'd get in on that.

anyways, I tried it on my direct buy version (from torchlightgame dot com) and it destabilized my PC, had to reboot.
I hadn't realized buying the game from different places would result in different versions of the game, or that there'd be mod issues.

I hope Runic does something about that before TL2 comes out, that's a real problem in my mind. Sure the game is cheap, but I'm not buying 2-4 versions of the same game just because I can't control where my friends buy their copy. Let alone potential problems porting saved games between the versions just so I can play w/the same character.... !
Post edited July 16, 2012 by rookshunter
A warning that Hotspot, a Torchlight Mod Manager, is incompatible with several of the more popular mods, and seems to be more trouble then it is worth. This goes for all editioins of Torchlight.
The Merchant Pack works
Post edited July 14, 2012 by NrlnDrgn