It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


I was just wondering if it is something I am doing wrong or the description on the webstie is wrong. I just got Thronebreaker and I am unable to select any other Audio type than English. The website shows it is available in the same languages as other Witcher games. Anyone else had this issue?
For the non Galaxy users wondering, you have to select the language when you run the offline installer. Options and in the bottom there will be an option to choose the language.