It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have swapped the Eye and waited for the ritual to finish. It backfires and the Trickster is killed or unconscious on the floor. Then I check the objectives, all checked. The game prompts me to the summary of the mission and after I push "continue" it loads the starting screen, without anything else.

Such a brilliant game has let me an anticlimatic feeling like a kick in the balls. Is there any workaround to load the ending scene? I don't want to watch it on YT, I have deserved it.

Ah, and the game doesn't load the credits either.

Note: played on hard. All the cutscenes and briefings worked flawlessly until now.

PS: game purchased and downloaded on december 2017 I think. I guess there is no new update after that: 1.25 ND

I'm guessing that I've found some bug because I remember I haven't seen the "mission complete" screen. The game goes out after the Trickster is defeated and loads the summary as if it was finished but not. I suspect that I did something during the swap of the Eye where the Trickster spotted me but somehow it continued doing the ritual. I did the swap in the beginning and very fast.
Post edited June 03, 2018 by sergtomas
No success. After I loaded a previous saving and I swapped the eye and got a new objective alert, after the demise of the Trickster, there is no mission complete prompt and I'm out of themission so no ending scene. Terrible.
Post edited June 03, 2018 by sergtomas
does the intro cutscene work? might need to reboot the computer.
The intro works as usual. From a new load of the game (just now) I've been able to load the credits too (I've never tried before because I waited to finish the game). On the other hand, yesterday, the main menu screen I was sent to was unable to load the credits but I did not test the intro.

Eventually I watched the final video in the folder (it's the Cs14.avi) but I don't know if the bonus mission has to be offered next, as per the wiki, the "blooper" mission.

I can try some tests in case you want to notice some bug or something since I have finished the game but I will not delete the savings.
not really, cutscenes not loading sometimes is a known issue, just rebooting the computer usually helps.

the bonus mission needs to be loaded manually, google it.