It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

1) Open your Thief Gold installation’s folder.

2) In a text editor, such as Notepad or Notepad++, open your user.bnd file and add the following two lines:
bind mouse_axisx mturn
bind mouse_axisy mlook
3) Save user.bnd and close it.

4) Open Thief Gold and make sure that Always Freelook is always set to On.

5) Load your game as normal.
uhh.. full mouselook is enabled by default?
voodoo47: uhh.. full mouselook is enabled by default?
For some strange reason, freelook wouldn't work correctly in my install of Thief Gold until I did all of those steps. That was why I posted those steps, in case anyone else ran into that situation.