It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Well waddya now...I got it working in the end!

After looking through as many of the other forums of people having the same invisible cursor issue with Thief 3, I decided to expand my search and have a look around for those experiencing similar issues with other game's menus.

One suggestion was to go into control panel > Apperance and personalisation > Text size etc > 100% size (default)

Yes, setting it to 100% resolved the invisible mouse cursor issue.

I had my windows setting as 150%.

This may not apply for everyone else who may experience the same this, but it sure as death and taxes worked for me.

Perhaps one of your lovely selves can develop a fix that can prevent users having to change windows settings to resolve this.

Thanks Snobel and others.

Back to

snobel: Still not much to suggest - in one of those threads, someone had it fixed by reverting to an older graphics driver, but I guess you tried that already?

Another place it's mentioned that the game can be confused by multiple input devices, so disabling your touchpad might be worth a shot. (Better do it thoroughly by disabling it in device manager and rebooting.)

A quick search brought up this, which says "disable aero" - have you tried that? (There is a couple other things in that thread too.)