It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi there,

I tried to refresh my memories about Thief, but I can't made Creative Alchemy to works. I have Creative Audigy RX card and installed Creative Alchemy. When I run TG, I can't choose EAX. After I quit the game there is a file in Thief Gold directory called dsoundlog.txt. There is a error message: "DirectSoundCreate : Failed to initialize Creative ALchemy, falling back to dsound.dll".

Any idea how to fix this? I could swear, that couple years ago I was able to run TG with EAX enabled on Windows 10.

PS. It's the same with or without Tfix 1.27.
yeah, standalone audio cards are more trouble than worth these days, it seems. open cam_ext.cfg with notepad, look for this;

; when using the OpenAL sound driver the default AL device may sometimes cause problems, in particular for
; on-board sound controllers. In those instances you can try an alternative AL device. Which other AL devices
; are available can be seen in the log file (when AL is enabled). It seems that usually the "Generic Software"
; device is available, which is a good one to try as an alternative.
;snd_oal_device Generic Software

uncomment (remove the semicolon) from snd_oal_device Generic Software. also, your audio card should have a control panel - any enhancements available should be disabled.
Post edited March 26, 2022 by voodoo47
Thank you Voodoo47 for you answer and your hard work for Thief community!

Creative Sound Blaster Audigy RX is not standalone card, but for PCI-E. I do not have a problem with playing with OpenAL enabled. It works. I'm just looking for solution to turn on EAX on default Hardware Acceleration having Creative Alchemy.

Dunno why but now I got this weird "Failed to initialize Creative ALchemy" message, though previously this worked fine. So the only way to get surround & EAX is OpenAL. I'm just afraid, that OpenAl isn't that good as native EAX with Alchemy... :)
aha, misunderstood you there. and yeah, a pci-e card would be a standalone piece of hw, that's what I meant. anyway, if it did work before, then maybe a driver update broke it? no other idea, unfortunately.
Ok, what I tried already:

- installed Creative Alchemy 1.4.5.0 (I had before a little bit older version);
- updated RX drivers from SBA5_PCDRV_L11_3_01_0056B to SBA5_PCDRV_L11_3_01_0059E;
- running Thief Gold in compatibility mode with Windows 7 & Windows XP
- run everything in administrator mode.

Nothing above works. There is still "DirectSoundEnumerateA : Failed to initialize Creative ALchemy, falling back to dsound.dll".

So I gave up, I'm playing with OpenAL...