It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Yes,
Renaming/moving/deleting both fiies: dxgi.dll and d3d11.dll should do the trick for any other app that uses own overlay (e.g. Bandicam, Overburner, Trixx) or app that injects shaders (e.g. SweetFX).
After patch 1.05 loading are 10 time more longer if theses two files (dxgi.dll & d3d10.dll) are missing.. not cool

RIP Steam Overlay
@Dolphix
I think that´s the wrong topic here, but anyway I can´t confirm that. Loadingtimes for me are the same as before by instinct.
Seems the files causing the issues were removed in 1.05, thanks GoG for fixing this!
Hello, Pertaining to your advice, it seems that I can only locate xinput1_3.dll in the X64bin folder. And I move out of the folder but to no avail. The game was working fine when I installed a week ago until yesterday, it cannot lanch anymore
when I click play. Pls advise on next action.
avatar
Lonewolf0223: Hello, Pertaining to your advice, it seems that I can only locate xinput1_3.dll in the X64bin folder. And I move out of the folder but to no avail. The game was working fine when I installed a week ago until yesterday, it cannot lanch anymore
when I click play. Pls advise on next action.
The game resumed working as a non-steam game again, when I moved/renamed Galaxy.dll from the bin\x64 directory.
Post edited June 07, 2015 by docvangogh
Hi, thanks for sharing but it don't seems to work for mine :(
I'm using MSI afterburner and AMD VCE H.264 codec - crash if start recording in-game. In menu everything is fine, as well as recording with CPU-based x264vfw, but the performance reduces greatly.
It was OK on 1.01 but now it is 100% crash if I start recording in-game.

Any tips?
avatar
Cedup: DO they even test this s**t?
Is it that uncommon today for people to record gameplay? I think it's not!
FIX THE GAME DICE, uhm I meant CPD!
Agreed, hell all they needed to do was ask the community if the game works whilst recording or with any 3rd party overlays if they were to lazy to test it themselves.

I could answer well,

- Dxtory crashes the game instantly if I start Dxtory before the game is loaded, if Dxtory is loaded after then it's fine.
- MSI Afterburner makes the game lag even more than it already does.
- Nvidia ShadowPlay crashes the game to a minimized state (even though this happens whilst not using ShadowPlay at all anyway)

Those are the only ones I have tested, I mainly use ShadowPlay and my game has crashed over 40 times, some crashes aren't even when ShadowPlay is in use so I don't believe ShadowPlay is to blame there.

Still please fix this mess CDPR :)
avatar
Firek: If you're experiencing these issue since today's DLC update, please use this temporary workaround.
You should move the following file outside of the binx64 folder:
d3d11.dll

The default installation folder for The Witcher 3 is C:GOG GamesThe Witcher 3 Wild Hunt

If this doesn't help, please try moving these to a different folder as well
xinput9_1_0.dll
xinput1_3.dll
xinput1_2.dll
xinput1_1.dll
opengl32.dll
GogGalaxyHooks.dll
dxgi.dll
dinput8.dll
dinput.dll
ddraw.dll
d3d9.dll
d3d8.dll
d3d10.dll
d3d10_1.dll
Wait doesn't the game need those DX**.dll files to load the game??
Post edited July 10, 2015 by RAMPAGE572
Hi all, have been directed @daaceking here as I am having issues with FRAPS where taking screenshots is causing the game video to freeze even though sound keeps going after Witcher 3 is closed via the Task Manager. It isn't till I close GOG Galaxy .exe using "End Process" that the sound stops.

I thought it was patch 1.07 that did this as I didn't have any problems till recently but reading this thread makes me think it was actually the latest DLC?

If so any ideas as to whether the solutions posted here will solve the issue?
Unfortunately none of these workarounds worked, specifically while using OBS (original) or OBS Studio. The game crashes every time the streaming is started with that program.
avatar
Dolphix: After patch 1.05 loading are 10 time more longer if theses two files (dxgi.dll & d3d10.dll) are missing.. not cool

RIP Steam Overlay
I have the same problem! With those two files, I can't run my steam controller which requires running the game as a non-steam shortcut. Without those files, I can run it in in Steam, but the load times are vastly longer. As in, game usually loads within one or two of the "pro tips," but without the two files, it will run through about 15 of them before loading. 10 seconds, to close to 60 (I haven't timed but thats a good estimate.
avatar
Dolphix: After patch 1.05 loading are 10 time more longer if theses two files (dxgi.dll & d3d10.dll) are missing.. not cool

RIP Steam Overlay
avatar
reignfyre: I have the same problem! With those two files, I can't run my steam controller which requires running the game as a non-steam shortcut. Without those files, I can run it in in Steam, but the load times are vastly longer. As in, game usually loads within one or two of the "pro tips," but without the two files, it will run through about 15 of them before loading. 10 seconds, to close to 60 (I haven't timed but thats a good estimate.
I'm having a similar issue. I added the TW3 .exe file into Steam as a non-steam game. For awhile launched and played fine in Big Picture mode, but now it doesn't. I tried deleting those d3d11.dll and dxgi.dllI files from the bin x64 folder, and it allowed TW3 to work for awhile as a non steam game. But recently after a couple Galaxy client updates, my save games stopped loading. I found that when I put those d3d11.dll and dxgi.dllI files back, my save games load once again, but the game will no longer launch through Steam Big Picture mode. When I remove them, I can launch TW3 in steam big picture, but then the save games won't load. I have to choose between launching the game through Steam, or loading my save game.

I am frustrated with GOG.com and their Galaxy client. I wanted to support the developers and get the game on GOG, but if they won't let me at least launch the game on Steam (so I can use Big Picture mode and play the game from my living room couch using my Steam Link and Steam Controller), then I feel a little betrayed in my choice to purchase through GOG, and going out of my way in order to give more of my money to GOG instead of Steam.
巫师3 诺维格瑞(码头隧道旁边) 、威伦(湖心岛向右边一直行驶岸边) 都有水面贴图bug 看着真令人不舒服 不知道是疏忽还是 无法修复了、、、