It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello everyone,

I feel like documenting an error that I just fixed, just in case anyone else out there runs into the same issue I had (it's a pretty niche problem).

I originally downloaded the game via GOG Galaxy from a friends account, back when the game first came out. Then a couple of weeks later I bought it on steam and transferred my files over so I wouldn't have to re-download. Then, after the most recent update I was unable to launch the game. It would briefly say I was playing it, the Witcher3 process would appear, then it would go away.

Here's how you fix this problem:

1. Go ahead and verify game cache in case you have NOT done that yet. It probably won't fix your issue, but it may.

2. Navigate to your gam'es directory, in my case it was: F:\Program Files (x86)\Steam\steamapps\common\The Witcher 3

3. Then go here: The Witcher 3\bin\x64

4. Delete galaxy.dll and any other mentions of galaxy (if you have any).

5. Start your game, it should work. (it may take ~30 seconds to boot up first time)


I hope this helps someone, as I really could of have used help when I had this issue.