It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
So far i've enjoyed this patch (because i'm near end game), so I didn't end up suffering as many others had with unequiped gear.

This is one of those things that needed to be communicated. In fact I think most people would accept these changes, with a bit of a heads up.

I think they are actually making the patching process harder on themselves by working to make sure current game saves can work correctly on newer versions. So much has changed in the game and to be honest...I'm surprised that my game saves still work as well as they do considering how many patch versions they work (I don't trust them mind you!).

I really like the patch, but my reasons for enjoying it is mostly the performance improvements. I've been tweaking the shadow settings for a while. In the inital release of the game, I could only get decent performance with shadowmaps set to 1024. With 1.05 & 1.06 I could up this to 2048 and get similar performance. With 1.07 I now have 3072 size shadow maps at the same performance (some credit to the latest AMD 15.7 drivers).

I have a few complaints..the old LOD ones. There seems to be new options in the user.settings file for configuring LOD, but they don't seem to do anything unfortunately. Argh...sorry way off topic.

I do feel that CDProjekt deserve a lot of praise for this patch, if not for what it brings in terms of features, at least for the consistent effort and dedication they have shown trying to fix the many problems in this game.

But things like this need to be talked about in the patch changelog in order to prepare people. I like the idea of having to be a higher level to enjoy the better witcher set gear, but man..if I suddenly found I couldn't wear my current set because of some hidden patch change...I would be fuming...not because CD Projekt RED are 'teh EVIL!', but because it disrupts my game, when I had no reason to expect it to.

I think CDProjekt had no real obligation to see that current 'in progress' games worked correctly with the patch...especially with the huge changes done to the interface. I'm impressed that it works with my save which has been modified so many times (I must of nearly used every single patch!), but really everyone would of been content by a simple statement during the patch release:

"Unfortunately due to the large numbers of changes this patch brings, we are unable to support current playthroughs. In order to take advantage of the new features and improvements within this patch, you will need to start a new game. Patching to 1.07 will render your old saves unplayable; we apologize for the inconvenience"
avatar
chromeforce172: After installing 1.0.7 and finishing the quest I was doing in my recent save, I was sent to meet Radovid on his boat. The guard took my enhanced feline swords and gave them back as soon as I left - but they went straight to my inventory and I cannot re-equip them. It just so happens that as of patch 1.0.7, enhanced feline gear requires you to be level 23, but I am level 20. So I'm basically running around unarmed, carrying the fine, expensive swords I used what seems like minutes ago in my pocket, about 5000 XP away from being able to use them again. I am pretty much screwed. Was that intentional or did you guys accidentaly press a button you should not have? What am I supposed to do now? Slay the monsters with my almost unskilled Igni?

Any help is very much appreciated!
I was just about to post the same problem because I don't know why they did this or what they were thinking, but it almost ruins the experience - its very aggrivating!! And because I have superior Ursine swords and superior Feline Armor, and some other superior ursine gauntlent and boots that were set at level 27 but now it is set for 30 , and once I entered a fists of fury fight i had to take my armor and swords off but now i cannot use them again for a long time because they are in my inventory, and I am at Level 27 and Now all of the equipment that formerly required 27 or lower now requires level 30 or higher, that could take a long time to acheieve when you just reached level 27!! Therefore, I am not going to attempt to play the game until this problem is resolved , but will be checking for fixes!!
Post edited July 20, 2015 by Morgul39
WARNING: do not hire a prostitute either as your items will be un-equiped.
Yeah this is the only thing I don't like about the patch.

I would have preferred they just nerf the witcher gear a little bit rather than changing the level requirements. But that's just me.

Honestly if you level up Quen armor is just an aesthetic choice.
Exactly. gear is fine as it is its QUEN that makes this game to easy. im lv 23 and i use superior griffin swords which have 26 lv req now. i have to avoid any disarming quests for 3 levels? thats insanely stupid and kills fun. couldnt they just nerf weapon stats a bit i wouldnt mind.
It was done to bring ll witcher gear in line with their quest levels and each other. Now all master crafted versions are lvl 34. This had to be done as i m quite certain new game+ is coming, then there is future expansions to consider.

The school gears represent a certain playstyle and before the patch wolven was objectively better, now they all are equal and become better if they match your play style.

What they should have done is put it up in the patch notes so people could be prepared that this was going to happen.

But anyways its done, water under the bridge.
avatar
zeypheruk: It was done to bring ll witcher gear in line with their quest levels and each other. Now all master crafted versions are lvl 34. This had to be done as i m quite certain new game+ is coming, then there is future expansions to consider.

The school gears represent a certain playstyle and before the patch wolven was objectively better, now they all are equal and become better if they match your play style.

What they should have done is put it up in the patch notes so people could be prepared that this was going to happen.

But anyways its done, water under the bridge.
What they should have done is simply make the enimies harder to beat if they wanted to make the game harder because there are other ways to approach increasing game difficulty, which seems to be the reason for doing this.
Yeah, with 1.07 my Witcher ended up naked cause I used Enh Cat armor, which was upped from 19th to 23rd lvl...
Seems they've done the same for the weapons, that I shouldn't be allowed to use, but they don't get unequipped.

I really hate that kind of changes that slightly ruin my game...
I'm kinda stunned at how many people are insisting that the Witcher gear should be nerfed, thus permanently decreasing its usefulness, because they're too lazy to get some new gear for a few levels... just spend some money, it's not like you're going to use those tens of thousands of crowns for anything else.
avatar
PDF: Yeah, with 1.07 my Witcher ended up naked cause I used Enh Cat armor, which was upped from 19th to 23rd lvl...
Seems they've done the same for the weapons, that I shouldn't be allowed to use, but they don't get unequipped.

I really hate that kind of changes that slightly ruin my game...
Hahaha, I had the same situation, me at lvl 21 witch enhanced Cat School Set. I go to visit whores and I cant equip my gear anymore (and don't have spare). Ok, np, I wont visit whore, next quest traveling to Skellige... bastard gets naked when he goes to bed and when pirates attack Geralt is out of the doors in his menacing underware. It was too funy for me to get too mad. In the end I reloaded previous save and went hunting Griffin set which served me until 23 :)