It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

noLogic: Where can i download patch? Why doesn't GOG correctly install patch?
Please go to Game's MORE (or sidebar right-click) menu and see version radio button there in the Settings. If the version you want is selected, please use MORE -> Manage installation -> Verify / Repair option