It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I Change to Fullscreen from "BORDERLESS WINDOW" No more Crashes!

Did it work for you to?
avatar
AnteRehn: I Change to Fullscreen from "BORDERLESS WINDOW" No more Crashes!

Did it work for you to?
one thing i noticed about this, if you were running fraps, maybe some other programs, they could prevent tw3 from going to full screen (go back to the menu & it wont have actually changed). just a note since fullscreen could theoretically = better performance
Yup i have to manually set the game to fullscreen everytime i start TW3. Dunno why it does this as i aint running anything in the background, quite annoying tbh (booting via galaxy tho).
Yea its annoying my settings always revert to borderless window.
May be that's the reason I never experienced any crashing. Running full screen since the first time.

For the settings to stay, did you try running the game as admin??
avatar
AnteRehn: I Change to Fullscreen from "BORDERLESS WINDOW" No more Crashes!

Did it work for you to?
Oddly, I had to change from fullscreen to borderless window in order to get it to stop crashing.
Game keeps reverting to borderless window for me, too -- and I'm unable to change it to fullscreen at all. Running as admin.
avatar
AnteRehn: I Change to Fullscreen from "BORDERLESS WINDOW" No more Crashes!

Did it work for you to?
Mine was defaulted to borderless, but I experienced crashing, especially when playing cutscenes. Switched to fullscreen, and haven't experienced a crash since; well, except when I tried adding the Steam overlay, which W3 did not like on my machine.

GTX 980
maybe there would be a command line argument for the exe (to add in the shortcut) to force starting in fullscreen...
or is there a little editable file with prefs somewhere in any folder from the user profile ?
The game just started crashing on me after I used the fov tweak, and set the user.config to read only.
Thanks for the info on how to stop the crashing.
Didnt crash after setting to fullscreen.
:)
I switched to fullscreen also - maybe that's why I don't crash anymore. I thought it was because of geforce experience, which I disabled.

GOG support page says this and that's why I didn't do it earlier.

"CHANGE DISPLAY MODE (FULLSCREEN vs BORDERLESS WINDOW vs WINDOWED)
Please try the different modes to see which works for you. Borderless window is the default option, and is the most compatible one. While it's a natural instinct for PC gamers to switch to fullscreen, please resist this temptation if you see the game crashing on you, after setting this option. ;)"
Post edited May 20, 2015 by Qessu
Fullscreen or any of the others are still crashing for us. Annoying that still no actual word from the devs. I get 10 minutes of I am lucky before it crashes. Have tried all the workarounds or fixes people are suggesting.
avatar
Ravensbane: Fullscreen or any of the others are still crashing for us. Annoying that still no actual word from the devs. I get 10 minutes of I am lucky before it crashes. Have tried all the workarounds or fixes people are suggesting.
Did you try the borderless/v-sync off/unlimited frame rate option?

That cleared up the menu lock-ups for me today, and I think I only had one issue with the screen going black during a cutscene in 10 or so hours of play.
My game crashed 15 mins after I have switched to full screen mode so it's not 100% fix.

This is more or less specific for each machine and it's HW/SW combo.

I'mt using the Galaxy client though. It may have something to do with it.