It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
kevinhuynh12: I cant install patch 1.03. It said " game installation not found, please reinstall" plz help me.
You need to install 1.0.2 patch first.
avatar
katatonicone: You need to install 1.0.2 patch first.
avatar
kevinhuynh12: I installed patch 1.02.
I've just tested it.
1. Installed preload 1.0.0 version
2. Installed 1.0.2 patch.
3. Installed 1.0.3 patch.

Works as intended. I suggest that you install 1.02. patch again and then try the 1.0.3 update.