It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I hope someone is also experiencing this because I have searched for days on the net for clues as to what has caused this issue.

Before last week I had been running 2x5970's in crossfire on Catalyst 12.6 (i think) and playing the hell out of the Witcher 2. It ran ok, enough that I could play it, but there was some obvious issues that game was having with my cards and drivers. Being fed up with having to constantly hold the hand of every game that I introduced to my 5970's with rarely any success, I gave up and ordered an EVGA GTX 680 FTW 4GB. Having played the witcher 2 so long, I was very much aware of the differences I saw when I booted it up on my new 680 for the first time. First thing I noticed was that it ran like a dream but then after a few minutes I witnessed something that I'd never witnessed before. Geralt's hair and any objects that hanging off of him that used physics ( i asume) were being very very erratic and bouncing unnaturally from side to side in such a way that I knew something was definitely wrong. This only happens when I move him, walking our running.

I did not notice any other physics based objects in the world exhibiting the same erratic behavior.Nothing changed software or hardware-wise other than my video card and the Display driver's, which are the 304.48 Beta drivers. As soon as I installed the card is when I began seeing this.

Please help if you can
Try playing with the settings. It IS normal for Geralt's hair to bounce as he walks, though.

Sounds like you have too much money.
Yes, that's just Nvidia PhysX at work. Perfectly normal.
I found a solution last night. Though this did not 100% fix the issue it did fix about 90% of it or enough to barely notice.

So once I fix the issue it appeared that there was more going on than the cracked out physics. Appears that mouse controls were very jumpy as well. There has to be something wrong with these Nvidia beta drivers ( 304.48 ) because I went in to the driver settings and changed the Render ahead frame limit to 1. That did it.

... I didn't think it was possible to have "too much money". Must be a Canadian thing.