It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi, I've searched high and low but it seems I'm the only one wanting this feature.

So - is there a way to disable the minimap altogether? I like finding the way through game landscapes on my own.