It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just installed the game again, after downloading it fresh and installing all patches.

Playing on Win8/64.

I have recently completed the intro section with the dragon and acquired an "incinerated" critical effect on myself. (The flames)

It should last for five seconds, but it never stopped. It's still shown as active in the "get into the monastery" section. As well as a critical effect with some blood drops, that started on a one second timer when I began the game in the tent with Triss. Still going on at an neverending "one second" three sections later.

Is this a known occurance, and if yes: Can I do something to end it?
I had the same problem (quite rarely, but not just once, throughout the game).
You could load the last savamegame.
And although I don't remember if it worked for me, you could create a new save game and reload it (so you don't lose progress).

Cheers !
Post edited April 15, 2013 by cosminbolohan
Sorry for the late reply, but: Thank you! :)
Just saving the game (with effects still active) and reloading that save worked for me.