It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
gozer: GOG really needs to add "update history" to games and list changes there when game is updated ... it is really anoying having to browse through forums to find out what was changed
THIS!
Thanks for the Mac version update. :D
avatar
JudasIscariot: Hi all,

We've uploaded a new DMG for The Witcher ( the_witcher_2.2.0.7.dmg ) that fixes an issue where some Nvidia cards were getting deadlocked on startup which resulted in a black screen.

If you are experiencing such issues, please download the new DMG :)

Thanks and have a nice day :)
think I'd rather have the notification actually on my shelf.... instead of oh gee which version what language nothing shows up new. I'm just waiting for Postal 2's expansion and it's late on Steam as it is.
So, is this the update that makes The Witcher actually work on Mac or is it still crashing every 5 minutes? Has any one tried it? I don't feel like downloading it unless it actually works.
avatar
Circles: So, is this the update that makes The Witcher actually work on Mac or is it still crashing every 5 minutes? Has any one tried it? I don't feel like downloading it unless it actually works.
this the update that makes The Witcher actually work?
yes
is it still crashing every 5 minutes?
no
Good witchering Mac users. Happy you can finally play thia game.
I haven't had time to get past the tutorial even though I am a PC owner.
Go Mac :)
Deleted by author
Post edited July 13, 2015 by MindsEyeSplinter
The Mac version was updated again on 20 November 2018. From the changelog:
Fixed an issue where additional content under "New Game" and "New Adventures" would not show up properly when playing the Mac version of the game.
Hi everyone,
I recently bought an Xbox One with The witcher 2 et 3. I began the 2 and loved it, so I want to play te first one, before to continue the second. But the first Witcher isn't on console and my only computer is a Mac Book Pro OS 10.6.8
And on Steam and here I see on minimum requirement: 10.8
But WTF the game is from 2008 isn't it?
So can I find a later version working on 10.6.8. Where?
Thank you all for help, cause I'm very desapointed :'(