It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi, all Witcher 1 mods (Total of 104) released here:

https://www.kirmiziperfect.com/category/games/the-witcher/

This includes lost mods like Flash mod, FCR etc.

Thanks Flix for giving me these mods.
avatar
grinninglich: Hi, all Witcher 1 mods (Total of 104) released here:

https://www.kirmiziperfect.com/category/games/the-witcher/

This includes lost mods like Flash mod, FCR etc.

Thanks Flix for giving me these mods.
Hey - do you have anything to do with that site?

I've recently downloaded the Witcher for the first time, and keen to use the mods. I've tried to sign up to kirmizi perfect, but I'm not receiving any validation email :/

Have checked my spam and other folders and no sign :(
------

edit: was contacted directly by admin of kirmiziperfect, who went above and beyond to make sure I got the reply - there was a problem with hotmail eating our messages. Have now signed up using a gmail account, and very happily downloading the witcher mods. Highly recommend any other GOGers out there to take a look.
Post edited August 12, 2017 by Tenpax
I'm playing Witcher 1 for the second time and just noticed these mods.

I read the guide, Installing the Best Mods. https://www.kirmiziperfect.com/installing-best-mods-for-the-witcher-1-guide/

Should I simply download and run every one?

Because I can't really see which are more important.

I have a pretty good PC i7, 4Ghz, 15Gb RAM, GTX 760 GPU. W10.

I have just downloaded and run the first, The 4GB Patch and it returned and error.

Anyone have any advice?

Are these mods of any use for W10 systems?