It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Odd issue. When trying to launch the game I cannot get it to load no matter what I try. This is the exact error I am receiving:

The procedure entry point ?sputn@?$basic_streambuf@DU?$char_traits@D@std@@@std@@QAEHPBDH@Z could not be located in the dynamic link library H:\(yadayada)\SYSTEM\witcher.EXE.

What I've tried: Verify game files, reinstall game, reinstall all .Nets/DirectXs/ETC, even tried reinstalling frigging Windows with no luck. I'm at a loss here peeps, any help would be nice.
No posts in this topic were marked as the solution yet. If you can help, add your reply
That error type is a typical symptom of a corrupt library (.dll), so you should dump your current installer and re-download that latest. If that doesn't work, uninstall Galaxy, dump those installers and re-download that too. You most definitely have a corrupt installation. Of what is the question...
avatar
Hickory: That error type is a typical symptom of a corrupt library (.dll), so you should dump your current installer and re-download that latest. If that doesn't work, uninstall Galaxy, dump those installers and re-download that too. You most definitely have a corrupt installation. Of what is the question...
Have tried that as well. I've downloaded through the gog app numerous times and I've tried installing the stand alone version as well. I have even ran the verify option before and after install as well with no issues. Thing is it does it with every exe inside of the system folder and it points to the actual exe as the issue for each as well.
avatar
saxile: Thing is it does it with every exe inside of the system folder
That's an alarming statement. Can you explain what you mean by that?
avatar
saxile: Thing is it does it with every exe inside of the system folder
avatar
Hickory: That's an alarming statement. Can you explain what you mean by that?
dijinni!.exe and witcher.EXE both give the same error, while launcher.exe and register.exe both work fine. It's just the stuff inside of the system folder that throw the errors.
avatar
Hickory: That's an alarming statement. Can you explain what you mean by that?
avatar
saxile: dijinni!.exe and witcher.EXE both give the same error, while launcher.exe and register.exe both work fine. It's just the stuff inside of the system folder that throw the errors.
Why have you installed the game in the system folder? That's just nuts.
avatar
saxile: dijinni!.exe and witcher.EXE both give the same error, while launcher.exe and register.exe both work fine. It's just the stuff inside of the system folder that throw the errors.
avatar
Hickory: Why have you installed the game in the system folder? That's just nuts.
*facepalm* The game install path is x:\program files (x86)\whatever else\The Witcher Enchanced Edition\System
avatar
saxile: The game install path is x:\program files (x86)\whatever else\
That's your problem right there. That is a 32bit Windows protected folder. Games should NEVER be installed there. Uninstall it. Then create a new folder with full administrative permissions, something like

C:\Games\

Install it there.
Post edited October 18, 2017 by Hickory
avatar
saxile: The game install path is x:\program files (x86)\whatever else\
avatar
Hickory: That's your problem right there. That is a 32bit Windows protected folder. Games should NEVER be installed there. Uninstall it. Then create a new folder with full administrative permissions, something like

C:\Games\

Install it there.
Not the issue. It's installed in the same folder I install all my other games in, a folder I created on my second game drive alone. I've even tried it on a different drive, in a different folder as well with the same error. I will try another reinstall into another directory however, but I'm 100% certain it's gonna be the same result.

Just an fyi, I'm a pretty advanced user. I've tried pretty much everything basic one could think of and have tried pretty much every various fix out there I could find for the game. Like I said though, never seem anyone with this issue. I'd understand if it was the Direct X dll error, but the dll it's throwing the error for is the exe itself. I'm wondering if I replace those exe with a known working pair if it'd work?
avatar
saxile: I'm wondering if I replace those exe with a known working pair if it'd work?
Something's not right with your information. If you downloaded the current installer and there is no corruption in the download, you'd have a working pair. I just don't get what you're saying. I will say it again, that error is a classic symptom of a corrupt library. Now that can also mean a fault on the hard drive, so don't forget that.
avatar
saxile: I'm wondering if I replace those exe with a known working pair if it'd work?
avatar
Hickory: Something's not right with your information. If you downloaded the current installer and there is no corruption in the download, you'd have a working pair. I just don't get what you're saying. I will say it again, that error is a classic symptom of a corrupt library. Now that can also mean a fault on the hard drive, so don't forget that.
Again, already stated that as well. Has been tried on both of my game drives thus far, two drives that have never had even a corrupt download in their service history.

And I've stated that myself, but the library it's stating that are corrupt are the dinjinn and witcher exes. That's why I went as far as reinstalling Windows itself. Has been since the launch of 10 anyhoo and the way I have my system setup I have minimal reinstalls to do, so really had nothing to lose in a fresh install.

I've tried installing it via Galaxy on both drives, and now going to try it via the offline installer on the other drive. The offline installer was downloaded on a third drive seperate than those as well. I will report back once install is completed and I've tested again.


EDIT:

Yep, nope, no change installing it in a base folder either. Get the exact same entry point error for witcher.EXE
Post edited October 18, 2017 by saxile
avatar
saxile: Yep, nope, no change installing it in a base folder either. Get the exact same entry point error for witcher.EXE
Where did you download the game from?
avatar
saxile: Yep, nope, no change installing it in a base folder either. Get the exact same entry point error for witcher.EXE
avatar
Hickory: Where did you download the game from?
gog.com and the gog galaxy app.
avatar
saxile: I'd understand if it was the Direct X dll error, but the dll it's throwing the error for is the exe itself.
Check your Security settings and A/V software. It's a Visual C++ error except as you note from the EXE. Don't think installing the redist will help in this case. I would also think a corrupt download, but you have already reinstalled/etc. Might want to send in a support ticket as well.
avatar
saxile: I'd understand if it was the Direct X dll error, but the dll it's throwing the error for is the exe itself.
avatar
Gydion: Check your Security settings and A/V software. It's a Visual C++ error except as you note from the EXE. Don't think installing the redist will help in this case. I would also think a corrupt download, but you have already reinstalled/etc. Might want to send in a support ticket as well.
Antivirus has nothing to do with it, completely disabled it, redownloaded on yet another drive via gog.com, installed on different drive, and still the exact same error... I'm 100% at a loss here. As for Visual C++, have all of them installed from fresh downloads and nothing else is throwing an error save Witcher. Witcher 2 runs flawlessly as does every other GOG game I have, steam game, app, and every other program on my system...