It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
Phoboss: Is there any way to get rid of the pixelation issue in cutscenes/dialogues?

I sort of remember it was possible to get rid of by setting the AF to the same value both in game and in the GFX control panel, but this isn't working for me.
If you are referring to what I think you are referring to, it appears that the best fix is to run in a 16:9 resolution rather than 16:10. I'm adding this to the first post.
avatar
Phoboss: Is there any way to get rid of the pixelation issue in cutscenes/dialogues?
Are you talking about pixelated or blurry cut scenes?

The blurry cut scenes bug should be fixed with the latest patch.
avatar
Waltorious: If you are referring to what I think you are referring to, it appears that the best fix is to run in a 16:9 resolution rather than 16:10. I'm adding this to the first post.
The 16:9 solution works, thanks Waltorious. It isn't really fun though, since I'm on a 16:10 screen and I do prefer fullscreen rather than windowed.

avatar
Kleetus: Are you talking about pixelated or blurry cut scenes?

The blurry cut scenes bug should be fixed with the latest patch.
Well to be fair it's horizontal lines that make everything look like it's pixelated.
It has something to do with lighting, since on medium quality and while under the effects of a cat potion it doesn't happen.
Post edited May 25, 2011 by Phoboss
In my experience, Witcher games sometimes become glitched for no apparent reason, yet the glitch often isn't repeated if you do the exact same things in another game. If you have a problem that isn't covered in the stuff that Waltorious kindly posted, above, the first thing to try is restoring a previous save.

Because of that, it's a good idea to save your Witcher game VERY often. Of course, if you accumulate a lot of saves, it will slow down your game, but you can store the bulk of your saves somewhere other than your The Witcher\saves folder. (I'm not suggesting that you just delete them, because sometimes the glitch happened and people didn't notice it, so they have to go back to a save from an hour or more back.)

So:

1. Save often.
2. If you have a problem, go back to a previous save and try from there. This will fix something like 95% of the little glitches that people encounter.
avatar
Phoboss: The 16:9 solution works, thanks Waltorious. It isn't really fun though, since I'm on a 16:10 screen and I do prefer fullscreen rather than windowed.
By the way, you can still run a 16:9 resolution fullscreen, but you will have thin black bars at the top and bottom of the screen, PROVIDED you have your scaling options on your graphics card set correctly. If those aren't set right, ti will stretch instead.
avatar
Waltorious: By the way, you can still run a 16:9 resolution fullscreen, but you will have thin black bars at the top and bottom of the screen, PROVIDED you have your scaling options on your graphics card set correctly. If those aren't set right, ti will stretch instead.
I'm on vga at the moment though, so no scaling. But I'll try this as soon as I get back to my dvi powered box.
My copy of "The Witcher" has been constantly crashing. In the first chapters that was bearable - I could play for 30 mins to an hour without a crash, but entering Trade Quarter (Chapter 3) changed that all. Game started crashing every 5 minutes and became unplayable. I have tried all the methods listed in the first post and none of them helped.
After that I decided to use Google and find other available methods to stop Witcher from crashing and I was lucky. I have already played for 4 hours without a single crash. So that's what I did (I am on Windows 7 Ultimate).

Method 1:
1. Press right mouse button on the folder where you installed "The Witcher Enhanced Edition".
2. Go to properties -> Advanced
3. Uncheck "Allow files in this folder to have contents indexed in addition to file properties"
4. Press OK and allow changes to be made to all folders and subfolders.
5. Download Defraggler
6. Install -> go to the program -> Action -> Defrag folder... -> choose your Witcher folder -> OK
7. Or I think you can just defragment the whole drive with a function available with Windows instead of doing steps 5-6.

Method 2 (note that it must only be used in 32-bit OSes):
1. First of all make sure that you have a fixed virtual memory of more than 3 GBs allocated on your machine:
a) RMB on Computer -> Properties -> Advanced system settings -> Performance -> Advanced -> Change
b) Highlight any of your drives -> Custom settings. Make sure you write the same number in both "Initial size" and "Maximum size". For example my number is 3840, which stands for 3.75 GB. Windows 7 and possibly Vista (I have never had Vista, so I don't know) allows you only write a number that is lower than your physical RAM (my physical is 4 GB, thus I have written 3.75 GB). Windows XP didn't limit your virtual memory and you could write any number you want (though it's inadvisable to choose a virtual memory more than twice as big as your RAM).
c) Press "Set". You might possibly need to restart your PC. Allocate your VM only on one of your drives (if you have more than one). Other drives should display "None".
2. Install this update if you have Vista without SP1. Operating systems starting Vista SP1 already has it included and XP doesn't need it.
3. If you have Vista or 7, Start -> All programs -> Accessories -> RMB on Command Prompt -> Run as Administrator.
4. bcdedit /export "C:\BCDBackup"
5. bcdedit /Set IncreaseUserVa 3072 (note where the spaces are).
NOTE: 3072 is the maximum you can use in this step, however any number between 2048 and 3072 can be used. Also obviously the number here can not exceed the number you chose in step 1b.
6. Reboot. WARNING: step 5 can possibly screw your computer even preventing it from booting. If that happens, boot it in safe mode, repeat step 3 and write:
bcdedit /import "C:\BCDBackup" (it will restore your computer to previous settings).

7. Steps 3-6 only work on 32-bit Vista and 7. If you have Windows Server 2003 or Windows XP Pro (Home is not supported), the steps are different.
8. Open C:\boot.ini file with a Notepad (it's a hidden file). Before doing anything, make a backup of the file.
9. Find a line that looks something like this:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
10. Add /3GB at the end of the line so it looks like this:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB
11. Save the file as boot.ini. Restart.
12. In case it fucks up your computer, restore the backup I asked you to make.

I used both of the methods I described here and all the crashes stopped. i don't know which of them actually helped or both of them. I'm only happy, I don't have to save every minute in the game anymore.
Post edited June 05, 2011 by beliar
Thanks for sharing that solution, beliar. Since the instructions are so long, rather than copying them to the first post of this thread I simply added a link to your post.
I'm running Windows 7 32-bit and my game was crashing everytime I tried to save it, then I did the BCDEDIT trick and it worked fine till chapter 3 when it started crashing all over the place for no reason.

After trying every method I found on the internet to fix this the only thing that worked was this:

1 - Disable Autosave.
2 - Stop using quicksave.
3 - Keep the last 15 saves and delete the rest. From now on manually save your game in these 15 slots always overwriting the older file.

I don't know why it worked but I played for 4 hours with no crash whatsoever after this fix and before I could barely play for 15 minutes. I think it has something to do with disk space because The Witcher save files are kinda big and if you don't overwrite your old saves frequently the save folder can go over 1 GB in a matter of minutes.

Hope this helps someone.
Also, if you run into anyone who has problems that none of these recommendations fix, ask them to try down clocking their video card. This fixed my problems as well as another poster here back in Spring.

This was a fix for consistent crashes.
avatar
Fayth: Also, if you run into anyone who has problems that none of these recommendations fix, ask them to try down clocking their video card. This fixed my problems as well as another poster here back in Spring.

This was a fix for consistent crashes.
Thanks, I added that fix to the first post.
I've had lights bleeding through the walls on multiple computers and multiple driver versions. (seems to be an SLI issue) The fix is below:

1. Go to Nvidia Control Panel.
2. Manage 3D Settings
3. Program Settings --> Add the Witcher .exe (not the launcher)
4. Go down to SLI Rendering Mode, Select-> Force alternate frame rendering 2
problem: Witcher wouldn't start due to missing d3dx9_35.dll file

I reformatted and repartitioned my computer and did a completely fresh install of Windows 7 64-bit, then downloaded and installed Witcher again. I first used the GOG downloader, and chose to install to a drive other than the C: drive. When trying to launch the game gave me the d3dx9_35.dll file not found error, I thought either the downloader or my choice of install directory were at fault.

I then painstakingly downloaded via http, and installed to C; like a good little user, but still got the error. I had just installed all available Windows updates the day before.

What worked for me was to install the Direct X SDK here:

http://www.microsoft.com/downloads/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en

But, there are other solutions offered here - just note I would be careful about just downloading the DLL:

http://answers.microsoft.com/en-us/windows/forum/windows_other-gaming/missing-d3dx935dll-for-the-game-witcher/7fad1791-5896-4113-910b-bc1aa57a6d31

I *LOVE* this game, so I'm very glad to have found a fix, and I really appreciate other gamers offering their fixes for crashy installs. <crosses fingers>
I just bought the game yesterday and when I try to run the game installer part 1it tells me I have a corrupted file. Is there anything I can do here?
avatar
Topshelf: I just bought the game yesterday and when I try to run the game installer part 1it tells me I have a corrupted file. Is there anything I can do here?
You should probably just redownload that part. You can also try using the GOG downloader instead of your browser, if you haven't tried that yet. If you did use the downloader, try using your browser.

The big files for the Witcher installer sometimes get corrupted while downloading.