It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I just bought this game, but I'm having two big issues.

I can't see any 3D scene. All i see is a a black box in the center with some text. This makes the game unplayable.

When I try to load a saved game, I can't click anywhere in the load screen.

My system: Arch Linux 4.19.10 with nvidia gtx 1060, 16GB of RAM and KDE Plasma as DE.


EDIT 2019-01-16: I tried it on an Ubuntu 18.10 with intel integrated and KDE Plasma with the same results. The game is unplayable.
Post edited January 16, 2019 by g.reventlov
The save game issue seems to be a locale related bug. Adding LANG="C" before "# Initialization" in "start.sh" works around this issue and allows loading previously saved games. The game is probably trying to parse floating point numbers from the save game using a locale dependent function which fails in locales that use commas as decimal separators. I have not figured out a way to solve the missing 3D scenes though.
avatar
borschty: The save game issue seems to be a locale related bug. Adding LANG="C" before "# Initialization" in "start.sh" works around this issue and allows loading previously saved games. The game is probably trying to parse floating point numbers from the save game using a locale dependent function which fails in locales that use commas as decimal separators. I have not figured out a way to solve the missing 3D scenes though.
Thanks. I did it and now I can load the game. One small improvement, but better than nothing. :)
I just installed the game on a different machine and used LANG="C" right from the start and now the 3D scenes work. Previously I was always loading a save game created without LANG="C" and it seems like that this save game contained corrupted data causing it to fail to display the 3D scenes. So if you start a new game with LANG="C" the 3D scenes should work. I guess they are also using the locale specific parser to load some coordinates for the 3D scenes and somehow those wrong coordinates end up in the save game.
avatar
borschty: I just installed the game on a different machine and used LANG="C" right from the start and now the 3D scenes work. Previously I was always loading a save game created without LANG="C" and it seems like that this save game contained corrupted data causing it to fail to display the 3D scenes. So if you start a new game with LANG="C" the 3D scenes should work. I guess they are also using the locale specific parser to load some coordinates for the 3D scenes and somehow those wrong coordinates end up in the save game.
Many thanks! you were right. The save game was somehow corrupted, while a new game works fine.