It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Okay, so I recently bought the Settlers bundle and was looking forward to trying out the 10th anniversary edition of Settlers 2.
However, after installing without problems I try and launch the game. It gives me a black screen (fullscreen) and starts playing some intro sound (though they are "stuttering" or looping, like a stuck record) and after a few seconds it crashes to the desktop.
There is no error message and there's still a small Settlers icon in the taskbar. Clicking the icon gives black screen for maybe a second, and then crashes back to desktop. The sounds stop playing a few seconds after the first crash to desktop.
I've been trying to look around but can't really find a fix.

System specs:
Windows 7 Ultimate 32-bit
Intel Core i5-3450 CPU 3.10 Ghz
4 GB Ram
AMD Radeon 7700 HD
AMD High Definition Audio Device
Realtek High Definition Audio
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
hasseborg: Okay, so I recently bought the Settlers bundle and was looking forward to trying out the 10th anniversary edition of Settlers 2.
However, after installing without problems I try and launch the game. It gives me a black screen (fullscreen) and starts playing some intro sound (though they are "stuttering" or looping, like a stuck record) and after a few seconds it crashes to the desktop.
There is no error message and there's still a small Settlers icon in the taskbar. Clicking the icon gives black screen for maybe a second, and then crashes back to desktop. The sounds stop playing a few seconds after the first crash to desktop.
I've been trying to look around but can't really find a fix.

System specs:
Windows 7 Ultimate 32-bit
Intel Core i5-3450 CPU 3.10 Ghz
4 GB Ram
AMD Radeon 7700 HD
AMD High Definition Audio Device
Realtek High Definition Audio
This might help, it helped me with my XP SP3 launch problem:

Hi, it seems that some laptop users are experience
some problems playing settlers 2 10th anniversary.

1 - a small windows apears on the top left coner,
and the game wont start.

2 - the log file \S2\dumps\Logfile*** shows:

.\Device\GraphicDevice.cpp 2778 : Invalid call

I pass this error by running "3D Analyse".
1 - load the EXE file
2 - selected --- force SW TnL ----
3 - then press run.

The game should start ok.

There are different 3D Analyse programs available - I downloaded mine from here: http://3d-analyze.softwareandgames.com/

If it worked, I Wish you a pleasent Settlers gaming
avatar
hasseborg: Okay, so I recently bought the Settlers bundle and was looking forward to trying out the 10th anniversary edition of Settlers 2.
However, after installing without problems I try and launch the game. It gives me a black screen (fullscreen) and starts playing some intro sound (though they are "stuttering" or looping, like a stuck record) and after a few seconds it crashes to the desktop.
There is no error message and there's still a small Settlers icon in the taskbar. Clicking the icon gives black screen for maybe a second, and then crashes back to desktop. The sounds stop playing a few seconds after the first crash to desktop.
I've been trying to look around but can't really find a fix.

System specs:
Windows 7 Ultimate 32-bit
Intel Core i5-3450 CPU 3.10 Ghz
4 GB Ram
AMD Radeon 7700 HD
AMD High Definition Audio Device
Realtek High Definition Audio
avatar
wrc666: This might help, it helped me with my XP SP3 launch problem:

Hi, it seems that some laptop users are experience
some problems playing settlers 2 10th anniversary.

1 - a small windows apears on the top left coner,
and the game wont start.

2 - the log file \S2\dumps\Logfile*** shows:

.\Device\GraphicDevice.cpp 2778 : Invalid call

I pass this error by running "3D Analyse".
1 - load the EXE file
2 - selected --- force SW TnL ----
3 - then press run.

The game should start ok.

There are different 3D Analyse programs available - I downloaded mine from here: http://3d-analyze.softwareandgames.com/

If it worked, I Wish you a pleasent Settlers gaming
It worked for me too, great thanks
I had the same problem - don't know about you, but my browser identified the file linked above as malware, so I asked the support team for another possibility to download the program.
Here it is:
download.chip.eu/en/3D-Analyze_85188305.html
Works like a charm, thanks gog-Team.
Is there a way to fix the black screen problem without having to use that "3D Analyse" demo program? Are there any configuration files to look at?

Update:
I finally got the game to work by running the main exe file as Admin. I also used the WinXP compatibility mode.
Post edited September 06, 2015 by IronArcturus
Hello,

I have the same problem on my Notebook (i7-4500U, HD4400, 8GB Ram).
Compatibility Mode / runas Admin didn't solve the issue - how can I get this to work?


Thanks!
avatar
wrc666: This might help, it helped me with my XP SP3 launch problem:

Hi, it seems that some laptop users are experience
some problems playing settlers 2 10th anniversary.

1 - a small windows apears on the top left coner,
and the game wont start.
Fucking great, now the game won't start now.

WTF, just a fucking white square on the top left and even with 3DA it doesn't work.

i know I shouldn't swear but I haven't had any reply in two weeks so obviously I'm running out of solutions I feel my pc is flawed now.
2 - the log file \S2\dumps\Logfile*** shows:

.\Device\GraphicDevice.cpp 2778 : Invalid call

I pass this error by running "3D Analyse".
1 - load the EXE file
2 - selected --- force SW TnL ----
3 - then press run.

The game should start ok.

There are different 3D Analyse programs available - I downloaded mine from here: http://3d-analyze.softwareandgames.com/

If it worked, I Wish you a pleasent Settlers gaming
avatar
BarkerHouse: It worked for me too, great thanks
avatar
Maverick-F1: Hello,

I have the same problem on my Notebook (i7-4500U, HD4400, 8GB Ram).
Compatibility Mode / runas Admin didn't solve the issue - how can I get this to work?

Thanks!
Fucking great, now the game won't start now.

WTF, just a fucking white square on the top left and even with 3DA it doesn't work.

i know I shouldn't swear but I haven't had any reply in two weeks so obviously I'm running out of solutions I feel my pc is flawed now.


Does anyone have a solution? Thread looks dead right now
avatar
Maverick-F1: Hello,

I have the same problem on my Notebook (i7-4500U, HD4400, 8GB Ram).
Compatibility Mode / runas Admin didn't solve the issue - how can I get this to work?

Thanks!
avatar
Grayef: Fucking great, now the game won't start now.

WTF, just a fucking white square on the top left and even with 3DA it doesn't work.

i know I shouldn't swear but I haven't had any reply in two weeks so obviously I'm running out of solutions I feel my pc is flawed now.

Does anyone have a solution? Thread looks dead right now
I had the same problem with the game now and was playing around a bit with diffrent options, I don't know if this will work for everyone, but it did just work for me.

If you go into the properties window for the game exe file, go to compatibility tab and check Disable fullscreen optimizations and Run this program as administrator. No compatibility mode or anything else and no extra programs, just those 2 options and it just turned on normally for me.

Hope it helps.
Thanks for the advice but it didn't do anything sadly...

This is seriously doing my head in and insofar among the millions of players no universal solution has been found to correct this issue.
avatar
Grayef: Fucking great, now the game won't start now.

WTF, just a fucking white square on the top left and even with 3DA it doesn't work.

i know I shouldn't swear but I haven't had any reply in two weeks so obviously I'm running out of solutions I feel my pc is flawed now.

Does anyone have a solution? Thread looks dead right now
avatar
arttu89: I had the same problem with the game now and was playing around a bit with diffrent options, I don't know if this will work for everyone, but it did just work for me.

If you go into the properties window for the game exe file, go to compatibility tab and check Disable fullscreen optimizations and Run this program as administrator. No compatibility mode or anything else and no extra programs, just those 2 options and it just turned on normally for me.

Hope it helps.
avatar
Grayef: Thanks for the advice but it didn't do anything sadly...

This is seriously doing my head in and insofar among the millions of players no universal solution has been found to correct this issue.
avatar
arttu89: I had the same problem with the game now and was playing around a bit with diffrent options, I don't know if this will work for everyone, but it did just work for me.

If you go into the properties window for the game exe file, go to compatibility tab and check Disable fullscreen optimizations and Run this program as administrator. No compatibility mode or anything else and no extra programs, just those 2 options and it just turned on normally for me.

Hope it helps.
avatar
Grayef:
for me it worked to enable both run as administrator and enable fullscreen optimizations.