It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


Finished the game just now. I encountered a few bugs, one of them pretty big.

1. In the puzzle where you trick the dragon into drinking the normal water I managed to dupe my bowl. I had 2 bowls of water and the water bottle. I think the process I took to end in this state was something along the lines of: Use water bottle on bowl, use bowl on well 1, use bottle on well 1, use bottle on bowl. I tried, but couldn't reproduce it. This resulted in the dragon scene always ending in failure, even though I had one bowl of normal water and one of poisoned water. I had to reload an earlier save (which I luckily had) to replay the section without the bowl duping.

2. When doing the crossword puzzle, the game stopped taking input. I saw the "click to start typing" message, after which none of my input went in the game. I couldn't exit this screen or do anything else.

3. After the cutscene where you are taken to the boathouse by the grocery store owner the black screen never disappearing on my first try. After loading a save and trying again this worked. I played the game on Windows 7 64-bit, fullscreen. I have two monitors, which occasionally seems to cause these graphics issues with AGS.

4. A few times my character's walking animation switched to something random. This happened at least in Patrick's apartment.
Post edited August 09, 2016 by Roisack
Thanks for the feedback. I'll pass this onto the developer and see if we can get an update out in due course to fix these (we know of the bowls issue, but the others are new to me, so thanks for reporting!)