It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

On Penumbra: Black Plague, one hour or so into the game, I ended up in this "Mental Realm" place that looks like the ship from the start of Overture.

After solving the initial puzzle and the spider egg thing, a dead dog spawns and the voice says "Sacrifice".

I do the sacrifice, the screen flashes and then the game just falls to pieces: the screen starts flickering like crazy (and doesn't stop flickering), I can't move, the sound gets all messed up, the textures look all messed up (from what little I can see) and there's a permanent subtitle that says "Warm in here".

This doesn't look normal. Looks like a major bug. It's impossible for me to progress from here. I tried everything (jumping, crouching, etc) but the character is just stuck there, unable to move.

Is this a known issue? Is there any solution to this?

I'm running the game under wine on Linux. Penumbra: Overture worked fine and I completed it with zero issues. But with Black Plague I've had several issues, with this one being the real showstopper.

I've done the basic troubleshooting steps already and reinstalled the game too, but that didn't fix it. This is a real bummer. Help?
Post edited June 29, 2023 by sobuy
No posts in this topic were marked as the solution yet. If you can help, add your reply
i'm a little late but i found a save that skip the buggy part.

i'm trying to send the link to the save but gog dosn't let me

drive 'dot' google 'dot' com/file/d/1hik9xSUjw457m8ICiwaG1xjjcOO7bYt8/view?usp=sharing
Post edited July 23, 2023 by little_stache
Not really offering a help here, but I have the same issue on the Steam using with GE-Proton8-7. It seens like the game scripting/logic don't work right with Wine. You can see even more issues before the "sacrifice" in the mental realm like:

* Its possible to use the syringe direct on the door reader (without collecting the blood from the corpse) and it will unlock it, creating 2 more copies of the syringe on your inventory.

* Using the syringe on the corpse without cleaning with the alcohol.

* Unlocking the door in the mess hall requires you to input a password in a computer: click "Ok" on the Password Input without typing anything and it will unlock the door.