It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have a nvidia Geforce GTX260. I know it's old, but my System was more than powerful enough to run Crysis and GTA4 and RAGE so i didn't check the hardware requirements for this seemingly slow little strategy game where the camera is usually a few hundred meters away, and the main gameplay is dialogue choices.
I was very sad when i found after downloading that it wouldn't even start, stating that my driver is too old and i should install 361.75, when the newest driver for my card is 342.01
I know i can't expect to run the newest games on old hardware, but man... can't really see why you need that much graphics power for this game.