It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi folks, I'm playing The legend of heroes - Trails in the Sky on Linux, right now, and seems to work flawlessly on Wine.

However, you must run the Config.exe before starting your first play in order to disable the opening cinematic and in order to change the default resolution and put your own inputs.

Best regards,
Sebastián Moncho

Tested with Ubuntu 14.04, 64 bits, Wine 1.6.2 and GPU Intel HD 3000.
Attachments:
Post edited July 31, 2014 by hasmster_ruso
Tested on Mint 17 64bit and Wine 1.6.2 here, GTX 760

Works flawlessly except the Logo and Opening Cinematic (game freezes) so make sure to disable them before playing.
In my case the game does not freeze if both cinematics are enabled, however if they are I've got a black screen that I can avoid by pressing ESC key twice.
Post edited July 31, 2014 by hasmster_ruso
I'm running CrunchBang with the debian testing repo's (essentially very close to what SteamOS would be, internally; sans compositor) with Wine 1.6.2 and I've had no issues that are related to Wine specifically. In fact, even before the patch I wasn't crashing at all!

Really, the only issues I've had have been some screen-tearing every so often (most of it is solved by turning compton off) and a crash that has to do with a single chest's empty dialogue, that I've already mentioned on the XSEED forums, and have reproduced on windows.

Really, beyond the movies in the beginning; the game really does run flawlessly, if not better than on windows.
I'm playing in openSUSE 13.1 (x86_64) with Wine 1.7.2 and works perfect. (AMD FX-8150 / Nvidia GTX 770 / 8 GB DDR3).

Wine with default config and the game [GOG.com > The Legend of Heroes – Trails in the Sky > Configuration Tool]

Device: HAL
Resolution: 1280 x 720 x 32 @ 60 Hz
Texture Quality: Standard
Texture Filtering: Anisotropic
Frame Limiter: Auto
High Resolution Fonts: On
Windowed Mode
Disable Movies: Logo & Opening
Attachments:
Works great so far on my MacBook Air (11.6" Late-2010, OS X 10.10.1). I'm running it in Wineskin using WINE 1.7.31. As others have mentioned, the only thing that needs to be done is to disable the logo and opening cutscene.
Just gonna update this topic, to tell you fine folks that I found a way to get the movies and falcom logo working (especially important if you want to transfer over your save from FC into SC when it launches!)

You're going to want to winetricks amstream, dsound, quartz, and gdiplus. Doing so will get the game running literally perfectly in WINE.
avatar
Theswweet: You're going to want to winetricks amstream, dsound, quartz, and gdiplus. Doing so will get the game running literally perfectly in WINE.
Nice! I take it the ending movie also works? Is this still with Wine 1.6.2?
avatar
Theswweet: You're going to want to winetricks amstream, dsound, quartz, and gdiplus. Doing so will get the game running literally perfectly in WINE.
avatar
Gydion: Nice! I take it the ending movie also works? Is this still with Wine 1.6.2?
This is with WINE 1.6.2, but I've also tested in 1.7.42-staging and it seems to work on both.

And yes; the ending movie plays too. I was able to create clear data on Linux using these settings.
Post edited May 12, 2015 by Theswweet
avatar
Theswweet: And yes; the ending movie plays too. I was able to create clear data on Linux using these settings.
Nice, thanks. I will have to play with this later. The game won't start and the config crashes to the debugger. Guess it doesn't like the updated nVidia drivers.
avatar
Theswweet: Just gonna update this topic, to tell you fine folks that I found a way to get the movies and falcom logo working (especially important if you want to transfer over your save from FC into SC when it launches!)

You're going to want to winetricks amstream, dsound, quartz, and gdiplus. Doing so will get the game running literally perfectly in WINE.
Thank you, but the intro movies still won't play. No big deal though, I can just put a tick in the options to disable them.
I'm using a 64-bits OS (Lubuntu 14.04 and the latest stable version of Wine)
Post edited June 17, 2015 by jorlin
Hey guys, any chance somebody could walk me through installing this? I'm on Ubuntu 15.04 with latest wine version, it goes well until the end of the installation where i get run time errors. Clicking OK on these then says it's installed fine but when I try to run it, I get the config screen, click launch game and it does nothing.

Runtime errors are:

Runtime Error (at 68:445)
Runtime Error (at 195:804): Null Pointer Exception.
Runtime Error (at 195:805): Out Of Stack Range.
Out of Global Vars range

Many thanks in advance.
Post edited August 08, 2015 by Melkren
Hi. I figured this out. Was to do with the sound, disabling music before loading up the game allowed it to work. Turning music back on when in game worked as well so no idea what's going on but oh well!
Ever since I bought the GOG version of this game I have been having all kinds of problems with the graphics. Half the time they don't show up, I get black screen with the character on it and I can't see anything. What's the deal, GOG??
Post edited August 24, 2015 by BFreeman03
Heads up; the Opening and Ending movies are broken on FC and SC right now. It doesn't seem to be a WINE issue since the Falcom logo movie - which uses the same format - and the "Next" movie in FC are still working on the latest patch.

If you can, do NOT update your FC install just yet. Wait for the problems to be fixed.