It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Sorry if this has already been addressed, but is there a timeline of when this problem will be fixed?

From my own experience and googling, it seems to be a common problem that this game can't be played on 1920x1080 resolution and hi-res fonts without crashing. I don't consider disabling the hi-res fonts a proper solution as it makes text very blurry.

If a solution has already been rolled out, can someone please point me to it? Otherwise, when can we expect this to be fixed?
Have you updated to the latest patch and generated a new config file? A new config file can be helpful on occasion. If you have and you are still experiencing crashes, you can always drop the resolution to the next lowest 16:9 resolution. The game wasn't designed for high resolution anyway. A couple of patches came out on Steam in the last few days and I saw a comment regarding improved handling of 1080p by one user. If that is the case, we'll hopefully see some improvement with the next patch.

Just a disclaimer: I don't have a 1080p screen to test this on. This is just speculation based on reading the Steam forums.
avatar
dk28: From my own experience and googling, it seems to be a common problem that this game can't be played on 1920x1080 resolution and hi-res fonts without crashing. I don't consider disabling the hi-res fonts a proper solution as it makes text very blurry.
I take it your desktop resolution is set to 1920x1080? The game can be touchy about switching resolutions. I'm actually running it 1440p in Wine as it would just crash when I tried to have it switch the res to 1920x1080. A Win 7 machine actually switches fine to 1920x1080 from 1600x900, but that one has old AMD drivers on it.

Guess you could try different drivers, but waiting for the new patch may be your best bet.
Post edited January 09, 2015 by Gydion
Thanks for the suggestions guys. The game seems to run fine for resolutions below 1920x1080, but I'm not a fan of the black border around the screen for these resolutions. I will probably play other games until the devs sort this out.

Some sort of official estimate from a dev. for a fix date would be nice.
avatar
dk28: The game seems to run fine for resolutions below 1920x1080, but I'm not a fan of the black border around the screen for these resolutions.
That's a scaling issue. You can fix that by enabling GPU scaling for your graphics card. The instructions on how to do this vary depending on if its Intel, Nvidia, or AMD but all of them should have the option.
avatar
dk28: The game seems to run fine for resolutions below 1920x1080, but I'm not a fan of the black border around the screen for these resolutions.
avatar
zaine-h: That's a scaling issue. You can fix that by enabling GPU scaling for your graphics card. The instructions on how to do this vary depending on if its Intel, Nvidia, or AMD but all of them should have the option.
Doesn't seem to work for me for some reason. I enabled GPU scaling and scale image to full size, but the border is still there.
avatar
dk28: Thanks for the suggestions guys. The game seems to run fine for resolutions below 1920x1080, but I'm not a fan of the black border around the screen for these resolutions. I will probably play other games until the devs sort this out.

Some sort of official estimate from a dev. for a fix date would be nice.
If you're running AMD, I've had a weird problem where the same thing happens to me with certain resolutions regarding having black borders around the whole screen. What I had to do was go to the resolution itself, and then set the scaling properties. Every now and again, it would still reset for some reason or another.

For example, at 1280x720 (due to me reinstalling windows recently), I get borders around the whole screen. So if I want to run something at 1280x720 without borders, I have to:

- Set it to 1280x720
- Go to "My Digital Flat Panels" and Properties to make sure GPU scaling was set
- And then go to Scaling Options and set the bar to 0.

For any smaller resolutions that have borders around the whole screen (pretty much any 16:9 resolution that isn't 1366x768 or 1080p for me), I have to do this. Afterwards, it seems to work fine. I also have to do this if I'm at a resolution that was set before, but with a different refresh rate for some reason.

If you're on NVIDIA, I'm sure there's probably similar steps that might work.

EDIT: Also, you could try running the game at 1920x1080 in windowed mode and then ALT+ENTER to go full screen from there. The game won't run if I launch it at that resolution in full screen mode directly for me, but ALT+ENTER after the game is running seems to work.

Disabling the intro videos and turning off Hi-Res fonts also seems to work for some people.
Attachments:
1-res.png (98 Kb)
Post edited January 16, 2015 by saldite